На главную Наши проекты:
Журнал   ·   Discuz!ML   ·   Wiki   ·   DRKB   ·   Помощь проекту
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
Модераторы: ANDLL, ALXR
  
> Использование VSCode/VSCodium , узнаём интерес форумчан
   
Используете ли вы VSCode/VSCodium
Гости не могут просматривать результаты голосования.
Гости не могут голосовать 
    Всем привет!

    Уже достаточно продолжительное время пользуюсь этой IDE. Да-да, при определенной настройке данный редактор вполне себе приобретает свойства полноценной IDE. Тут рекламировать и расписывать все ништяки не не буду, просто хочу найти собеседников по сабжу. Будет "команда" - найдется что обсудить.

    Ссылки:


    Кто интересовался, тот в курсе различий. VSCodium - это форк с открытым кодом VSCode-проекта. Cо своим, практически параллельным репозитарием, и с совместимостью установки расширений на уровне формата VSIX.

    user posted image
      Какие языки поддерживает?
      Только Си?
        Видимо поддерживает вообще все, если хорошо форкнули, включая какой нибудь TypeScript.
        Ты лучше расскажи, чем оно и правда лучше.
          Цитата vot @
          Какие языки поддерживает?
          Только Си?

          Поддержка туевой хучи языков осуществляется подключением и настройкой расширений. Сложно сказать - что там не поддерживается :lol:

          Цитата Бобёр @
          Ты лучше расскажи, чем оно и правда лучше.

          Дело конечно субъективное, и не понятно "лучше чего", но попробую перечислить отсебятину:
          • Изначально я начал пользоваться для работы с HTML, JavaScript и JSON - там есть базовая встроенная поддержка
          • Потом подключил расширения для PHP
          • Потом подключил расширения для Laravel
          • Потом подключил расширения для SQL (PostgreSQL и MySQL)
          • Потом подключил расширения для Perl
          • Потом подключил расширения для Lua
          • Потом подключил расширение для работы с удаленным Линупсом по SSH, это вообще по бесту!!! :good:

          Теперь собираюсь переходить с QtCreator'а для С/С++. Последние версии его уже просто бесят! В QtCreator установил комплект i686-w64-mingw32.shared, а потом пытаюсь установить i686-w64-mingw32.static - так эта зараза ругается, мол компилятор с таким триплетом уже установлен ... и сска удаляет его без вариантов!!! >:( Убил тучу времени, чтобы исхитриться и добавить... А вот тут это делается просто ручной правкой конфига.

          Ну как-то во так. До Ruby и Rust пока руки не доходят, но проверил - там для этого тоже есть расширения.

          PS. И да, обнаружил отсутствие норм поддержки ассемблера, вернее flat assembler - я об этом писал уже тут. Костыль нашел, но решил замутить по фэншую свое расширение. Дело времени.
            user posted image
            Если хотите получить портабельную версию VSCodium (наверное и VSCode) - сразу после разворачивания скачанного архива, перед первым запуском, создайте папку data внутри, ну - рядом с папкой bin. Теперь настройки будут хранится там, а не "размазываться" по профилям. VSCodium сам обнаружит эту папку, ничего настраивать не нужно.
              Цитата Majestio @
              VSCodium - это форк с открытым кодом VSCode-проекта

              vscode тоже открыта. Единственное, чем отличается codium - выпилили телеметрию от ms (и впилили свою :D ).. А в остальном это идентичные продукты, собирающиеся из одних и тех же исходников.
              0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
              0 пользователей:


              Рейтинг@Mail.ru
              [ Script execution time: 0,1143 ]   [ 17 queries used ]   [ Generated: 26.11.22, 13:32 GMT ]