На главную Наши проекты:
Журнал   ·   Discuz!ML   ·   Wiki   ·   DRKB   ·   Помощь проекту
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
  
    > gemfile , нубский вопрос
      собственно, а чем отличается:
      ExpandedWrap disabled
        gem %ololo%, '~> 1.0'


      от
      ExpandedWrap disabled
        gem %ololo%, '1.0'
      :rolleyes:
        В первом случае: ">1.0" + "<= 1.1"
        Сообщение отредактировано: deil -
          Цитата deil @
          В первом случае: ">1.0" + "<= 1.1"

          Хм... т.е. только инкремент минорной версии я так понял? Ну т.е. апдейты с 1.1.0 по 1.1.9999 (и т.д.), в основном по принятым понятиям - багфиксы и проч. Включая апдейты аналогичные: eventmachine-1.0.0a1 -> eventmachine-1.1.0b1.

          Опять же, исходя из логики - "~~>" инкремент 1.0.1 -> 1.1.1? :huh:
            Не обязательно минорной. Может быть и "~>1" - тогда это будет все версии от 1.х до 2.0.
            Детали здесь: http://docs.rubygems.org/read/chapter/16#page74
              О, спасибо. Теперь я наконец понял :yes:
              0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
              0 пользователей:


              Рейтинг@Mail.ru
              [ Script execution time: 0,0188 ]   [ 15 queries used ]   [ Generated: 8.02.23, 23:16 GMT ]