На главную Наши проекты:
Журнал   ·   Discuz!ML   ·   Wiki   ·   DRKB   ·   Помощь проекту
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
  
    > Проблема установки Ruby на Mac
      При установке Ruby возникает следующая проблема (имя учетки michaelpak):
      ExpandedWrap disabled
        MacBook-Air-Michael:~ michaelpak$ rvm -v
         
        rvm 1.14.10 (master) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]
         
        MacBook-Air-Michael:~ michaelpak$
        MacBook-Air-Michael:~ michaelpak$ ruby -v
        ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]
        MacBook-Air-Michael:~ michaelpak$
        MacBook-Air-Michael:~ michaelpak$ rvm install 1.9.2
        Fetching yaml-0.1.4.tar.gz to /Users/michaelpak/.rvm/archives
        Extracting yaml-0.1.4.tar.gz to /Users/michaelpak/.rvm/src
        Configuring yaml in /Users/michaelpak/.rvm/src/yaml-0.1.4.
        Error running ' ./configure --prefix="/Users/michaelpak/.rvm/usr"  ', please read /Users/michaelpak/.rvm/log/ruby-1.9.2-p320/yaml/configure.log
        Compiling yaml in /Users/michaelpak/.rvm/src/yaml-0.1.4.
        Error running 'make ', please read /Users/michaelpak/.rvm/log/ruby-1.9.2-p320/yaml/make.log
         
         
        Database file /Users/michaelpak/.rvm/config/packages does not exist.
         
        Installing Ruby from source to: /Users/michaelpak/.rvm/rubies/ruby-1.9.2-p320, this may take a while depending on your cpu(s)...
         
        ruby-1.9.2-p320 - #downloading ruby-1.9.2-p320, this may take a while depending on your connection...
        ruby-1.9.2-p320 - #extracted to /Users/michaelpak/.rvm/src/ruby-1.9.2-p320 (already extracted)
        ruby-1.9.2-p320 - #configuring
        Error running ' ./configure --prefix=/Users/michaelpak/.rvm/rubies/ruby-1.9.2-p320 --enable-shared --disable-install-doc --with-libyaml --with-opt-dir=/Users/michaelpak/.rvm/usr ', please read /Users/michaelpak/.rvm/log/ruby-1.9.2-p320/configure.log
        There has been an error while running configure. Halting the installation.
        MacBook-Air-Michael:~ michaelpak$

      В чем проблема?
        Цитата
        please read /Users/michaelpak/.rvm/log/ruby-1.9.2-p320/yaml/configure.log
          ExpandedWrap disabled
            MacBook-Air-Michael:~ michaelpak$ cat /Users/michaelpak/.rvm/log/ruby-1.9.2-p320/yaml/configure.log
            [2012-07-31 13:33:37]  ./configure --prefix="/Users/michaelpak/.rvm/usr"  
            checking for a BSD-compatible install... /usr/bin/install -c
            checking whether build environment is sane... yes
            checking for a thread-safe mkdir -p... config/install-sh -c -d
            checking for gawk... no
            checking for mawk... no
            checking for nawk... no
            checking for awk... awk
            checking whether make sets $(MAKE)... no
            checking for gcc... no
            checking for cc... no
            checking for cl.exe... no
            configure: error: in `/Users/michaelpak/.rvm/src/yaml-0.1.4':
            configure: error: no acceptable C compiler found in $PATH
            See `config.log' for more details
            Цитата MichaelPak @
            no acceptable C compiler found

            Ну так тебе ж черным по белому написали, что нужен GCC :)
              Цитата Мяут-Настоящий @
              Ну так тебе ж черным по белому написали, что нужен GCC

              А не подскажите, как именно надо исправить исправить ошибку?
                  Разобрался с проблемой. Xcode юзает LLVM версию GCC. А нужна non-LLVM версия.
                    Поздно защел, но все-же. Ruby в Mac Os X по-дефолту есть. А если хочется работать с rvm, то придется руками ставить gcc 4.2.
                    0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                    0 пользователей:


                    Рейтинг@Mail.ru
                    [ Script execution time: 0,0287 ]   [ 15 queries used ]   [ Generated: 8.02.23, 23:28 GMT ]