На главную Наши проекты:
Журнал   ·   Discuz!ML   ·   Wiki   ·   DRKB   ·   Помощь проекту
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
Страницы: (2) [1] 2  все  ( Перейти к последнему сообщению )  
    > ExtJs, Error installing sass:invalid gem format for C:/Ruby193.... , ne mogu ustanowit sass --version=3.1.1
      Xochu pomenat temu na ExtJs, i wot takaja oshibka pri pereustanowke sass, kto stalkiwalsa?

      Proshu proshenija, netu kirilici na etom koputere.

      ExpandedWrap disabled
        C:\Ruby193\bin>gem install compass --version=0.11.1
         
        Fetching: sass-3.1.10.gem (100%)
        Fetching: compass-0.11.1.gem (100%)
        Successfully installed sass-3.1.10
        Successfully installed compass-0.11.1
        2 gems installed
        Installing ri documentation for sass-3.1.10...
        Installing ri documentation for compass-0.11.1...
        Installing RDoc documentation for sass-3.1.10...
        Installing RDoc documentation for compass-0.11.1...


      ExpandedWrap disabled
        C:\Ruby193\bin>compass -v
         
        Compass 0.11.1 (Antares)
        Copyright (c) 2008-2011 Chris Eppstein
        Released under the MIT License.
        Compass is charityware.
        Please make a tax deductable donation for a worthy cause: http://umdf.org/compass

      ExpandedWrap disabled
        C:\Ruby193\bin>sass -v
         
        Sass 3.1.10 (Brainy Betty)


      ExpandedWrap disabled
        C:\Ruby193\bin>gem uninstall sass
         
        You have requested to uninstall the gem:
                sass-3.1.10
        compass-0.11.1 depends on [sass (~> 3.1)]
        If you remove this gems, one or more dependencies will not be met.
        Continue with Uninstall? [Yn]  y
        Remove executables:
                sass, sass-convert, scss
         
        in addition to the gem? [Yn]  y
        Removing sass
        Removing sass-convert
        Removing scss
        Successfully uninstalled sass-3.1.10


      ExpandedWrap disabled
        C:\Ruby193\bin>gem install sass --version=3.1.1
         
        ERROR:  Error installing sass:
                invalid gem format for C:/Ruby193/lib/ruby/gems/1.9.1/cache/sass-3.1.1.gem





      ExpandedWrap disabled
        C:\Ruby193\bin>ruby -v
        ruby 1.9.3p0 (2011-10-30) [i386-mingw32]
        Цитата Killer_13 @
        Proshu proshenija, netu kirilici na etom koputere.

        Если обратишь внимание, над текстовым полем есть кнопочка TRANSLIT...
        А также имеется кнопочка "Русская клавиатура"...
        попробуй воспользоваться ;)
          Оч полезное сообщение, по теме вы мне очень помогли. :(
            А я вообще не врубаюсь, при чем тут JS и ruby...
            Хотел было погуглить на тему sass, но времени не было... так что по теме сказать нечего...

            А так писать-то у нас принято по русски, специально функции разработали для транслита, а люди не пользуются... вот и приходится напоминать 8-)
            Сообщение отредактировано: fatalist -
              Чуток проясню, речь идет о ExtJs theming

              http://www.sencha.com/learn/theming/
              http://www.rallydev.com/engblog/2011/10/07/a-guide-to-custom-themes-in-extjs-4/

              после
              ExpandedWrap disabled
                > gem install compass --version=0.11.1


              ExpandedWrap disabled
                >gem list sass -r
                 
                *** REMOTE GEMS ***
                 
                sass (3.1.10)
                sass-align (0.1.1)
                sass-extractor (0.0.1)
                sass-on-heroku (0.9.0)
                sass-rails (3.1.5)
                sass-tools (0.1.12)
                sass_on_heroku_with_rack (0.0.2)
                sassafras (0.2.0)
                sassator (0.2.0)
                sasset (1.0.0)
                sassy (1.0.0)
                sassy-buttons (0.0.7)
                sassy-text-shadow (0.0.2)
                sassy_noise (0.1.4)


              после удаления sass
              ExpandedWrap disabled
                >gem uninstall sass

              ExpandedWrap disabled
                You have requested to uninstall the gem:
                        sass-3.1.10
                compass-0.11.1 depends on [sass (~> 3.1)]
                If you remove this gems, one or more dependencies will not be met.
                Continue with Uninstall? [Yn]  y
                Remove executables:
                        sass, sass-convert, scss
                 
                in addition to the gem? [Yn]  y
                Removing sass
                Removing sass-convert
                Removing scss
                Successfully uninstalled sass-3.1.10


              ExpandedWrap disabled
                >gem install sass --version=3.1.1
                 
                Fetching: sass-3.1.1.gem (100%)
                Successfully installed sass-3.1.1
                1 gem installed
                Installing ri documentation for sass-3.1.1...
                Installing RDoc documentation for sass-3.1.1...


              Хах, на другом компьютере инсталлировалось, что сделать чтоб на том комп что ошибка инсталлировать, снести и наново поставить? Или что посоветуете?
              Спасибо за помощь.


              Все установил, заработало.
              Только я не понимаю как ввести команду
              ExpandedWrap disabled
                sencha slice theme -d extjs -c resources/css/my-ext-theme.css -o resources/images -v

              windows:>cmd
              ???

              Цитата fatalist @
              А я вообще не врубаюсь, при чем тут JS и ruby...

              Compass нужен для компиляции sass в css
                Цитата Killer_13 @
                Оч полезное сообщение, по теме вы мне очень помогли.

                я вот, например, сообщения транслитом не читаю вовсе. принципиально.
                  Цитата Demon_id @
                  я вот, например, сообщения транслитом не читаю вовсе. принципиально.

                  Ну все, все, хватит бочку котить. :)
                    Killer_13, я вообще не понимаю очем речь... Не про ExtJs я как бы в курсе... но остального не понимаю...

                    Тут какбы разговоры идут про браузерный JavaScript обычно... Дык его компоненты никуда и не устанавливают... включают в страницы скрипты и все... а куда у тебя что устанавливается, это для меня лично загадка...
                    Может в какой-нибудь другом разделе это все отобразить?
                      Цитата fatalist @
                      Killer_13, я вообще не понимаю очем речь... Не про ExtJs я как бы в курсе... но остального не понимаю...

                      Я рассуждал так, - если здесь говориться про ExtJs, то кто0то из разработчиков сталкивался со сменой дизайна(темы) ExtJs. Для изменения темы, нужно то что я писал, compass 0.11.1 и sass 3.1.1, если наверное здесь никто с таким не сталкивался, то может перенести все-таки в раздел с РУби?
                      Шкурка в ExtJs проектируется с помощью sass, с помощью compass мы компилируем sass в css.

                      Может теперь яснее? Спасибо что пытаетесь вникнуть, что я имею введу.
                        Я просто не в курсе, что есть Руби (или хотя бы с чем его едят :) )
                        Но по всей видимости вопрос явно не относится к использованию ExtJS в контексте клиентского JS...
                        Пойду поищу, есть ли у нас раздел про Руби...
                          Так, это все на винде происходит???
                            Цитата Мохнатый @
                            Так, это все на винде происходит???

                            да
                              Просто это уже неоднократно обсуждалось на рубишных ресурсах - не нужно писать на RoR по виндой!!!
                              Никто из тех, кто работает с RoR, не работает по виндой. Linux или Mac!
                              Из-за того, что никто с виндой не работает, никто не сможет Вам нормально подсказать в чем проблема. Поэтому мой совет - это поднять Linux на виртуалке и там все настроить. Проблемы вы свои решите, и более того, не огребете их в дальнейшем.
                                Цитата Мохнатый @
                                Просто это уже неоднократно обсуждалось на рубишных ресурсах - не нужно писать на RoR по виндой!!!
                                Никто из тех, кто работает с RoR, не работает по виндой. Linux или Mac!
                                Из-за того, что никто с виндой не работает, никто не сможет Вам нормально подсказать в чем проблема. Поэтому мой совет - это поднять Linux на виртуалке и там все настроить. Проблемы вы свои решите, и более того, не огребете их в дальнейшем.


                                Вас понял, а если я эти репозитории(нужные версии sass и compass) или как это назвать, скопирую с компьютера где они работают на комп где я это установить не могу, Ruby примет все это, или эти пакеты при установке прописываются где-то еще?
                                Спасибо.
                                  Нет, так у тебя не получится. К тому же я не знаю, как ты там среду настроил - cygwin, mingw или вообще пользуешься виндовыми сборками.
                                  0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                                  0 пользователей:


                                  Рейтинг@Mail.ru
                                  [ Script execution time: 0,1066 ]   [ 15 queries used ]   [ Generated: 9.02.23, 00:43 GMT ]