На главную Наши проекты:
Журнал   ·   Discuz!ML   ·   Wiki   ·   DRKB   ·   Помощь проекту
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
  
    > IDE для Ruby
      Известно, что создатели NetBeans выпилили руби в 7 версии. На чем теперь будем писать? Попробовал JetBrains RubyMine - пока не нравится, интерфейс кривой какой-то, дебаг запустить не смог, постоянно зависает, особенно при открытии вкладок (к примеру дерево проекта).
      gedit + gmate хорош, как блокнот с подсветкой синтаксиса, но много чего не умеет.
        Я вчера как раз поставил Ruby Mine потестить. Правда, не успел по акции прикупить =(

        Если не понравится - собираюсь продолжать жить на NB6.9.1. Там жеж всё работает, привычно и стабильно.
        Возможно нет поддержки 3х рельс, но я их еще и не щупал. Да и в принципе особо поддержкой рельс я там и не пользовался.
          Я пользуюсь триалом от RubyMine. Дебаг наладил, но тормозит он жутко.
          Что значит нет поддержки 3х рельс в НетБинс? Указал в гемфайле что рельса третья и поехал. IDEшке-то какая разница в принципе.
            угу, в gemfile 3-е рельсы, и bundle update/install и в путь
              Могу сравнивать лишь IDE для Ruby On Rails.
              IDE обеих, NetBeans и RubyMine, тормозные. Последняя, вместе со своими наворотами, привносит и дополнительную неразворотливость. Очень ресурсоёмка. Пользуюсь ею уже второй месяц.
              Более удобна в отношении контроля версий, отображения дерева проекта и "умнее" в отношении каркаса (framework) Rails в общем. Мы работаем с Rails последних версий ветки 2.x.
              Что касается вопроса: заплатить за RubyMine или оставаться на NetBeans - однозначного ответа дать не могу. Время покажет.

              Других заметных игроков для каркаса Ruby On Rails я не вижу. А для одного лишь Ruby может хватить и любого программерского редактора.
                Мохнатый, да хрен его знает, "что значит поддержка 3х рельсов" :) Мало ли!
                  Да умеет НетБинс поддерживать Rails 3.
                  Сейчас пользуюсь gedit + gmate + embedded terminal. Кстати удобно!
                    я пользую VIM и набор скриптов от akitaonrails. Очень радует :)
                      А я зафанател от RubyMine
                        подниму тему, хоть и старенькая=)
                        Цитата Мохнатый @
                        Сейчас пользуюсь gedit + gmate + embedded terminal. Кстати удобно!

                        это я так понял все под Gnome, да? интересно а под Kde, замена этого всего есть
                        Официально да, из NetBeans убрали поддержку Rails, но плагин то все равно ставиться или со временем и его не будет?
                          Цитата Cepheus @
                          это я так понял все под Gnome, да? интересно а под Kde, замена этого всего есть

                          Да, под KDE очевидно Kate, хотя KDEшники меня поправят скорее всего.

                          Цитата Cepheus @
                          Официально да, из NetBeans убрали поддержку Rails, но плагин то все равно ставиться или со временем и его не будет?

                          Плагин отдали на откуп коммьюнити. Можешь подключиться к разработке :)
                            Перешёл на http://www.sublimetext.com/ , лучше редактора нет:)
                            0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                            0 пользователей:


                            Рейтинг@Mail.ru
                            [ Script execution time: 0,0318 ]   [ 15 queries used ]   [ Generated: 8.02.23, 23:10 GMT ]