На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
! Правила раздела:

  • Перед тем, как задать вопрос, желательно почитать документацию и воспользоваться поиском.
  • Когда задаёте вопрос, то обязательно указывайте платформу (7.7, 8.0, 8.1, 8.2, etc), причем желательно в заголовке. Если речь идёт о типовой конфигурации, то указывайте её название и релиз. Текущие версии можно посмотреть здесь.
  • Ещё раз напоминаем о необходимости соблюдать не только правила, но и законы. Уважайте авторские права.

Высказать своё мнение о модераторах раздела можно здесь: evGenius
Модераторы: evGenius
  
> ERP 2.4.11 (БСП 3.0.3) Ошибка при расшифровке внешнего отчета, Неизвестное имя формы Имя: "ВнешнийОтчет.[ИмяОтчета].Форма"
Доброго дня!

Сделал отчет на СКД, добавил его в дополнительные отчеты. Сделал второй отчет на СКД, который должен расшифровывать данные первого отчета.
Обработку расшифровки сделал по фэн-шую, как и положено, доработкой модуля ОтчетыКлиентПереопределяемый.

Теперь о проблеме

Формирую первый отчет, вызываю расшифровку, второй отчет раскрывается с переданными параметрами и формируется как и положено.
Закрываю пользовательский сеанс 1С. Снова захожу, открываю отчет, вызываю расшифровку, вываливается с ошибкой

Цитата
Неизвестное имя формы Имя: "ВнешнийОтчет.[ИмяОтчета].Форма"


Обновляю второй отчет из файла, и раз - расшифровка снова работает, но только в моем сеансе и на время сеанса.
А надо чтобы работало у всех пользователей и постоянно.

Кто сталкивался? Уже не знаю куда копать...

Добавлено
Если не обновлять второй отчет, а просто открыть через "Отчеты раздела" и сразу закрыть, то расшифровка начинает работать :wall:
[А что Если… КонецЕсли]
Ну тут либо добавлять отчёт в конфигурацию или расширение, либо доработать механизм дополнительных отчётов и при начале сеанса программно их все подгружать. До этого о внешних отчетах 1с ничего не знает.

Добавлено
Или в момент вызова проверять и загружать его программно.
Цитата evGenius @
Или в момент вызова проверять и загружать его программно.

Да, тоже пришел к такому выводу. Проверяю этот вариант.
[А что Если… КонецЕсли]
Да. Спасло подключение внешней обработки до вызова расшифровки

ExpandedWrap disabled
    ВнешнийОтчетСсылка  = ПолучитьСсылкуНаВнешнийОтчетПоИмениНаСервере("Процент поступления");
    ИмяВнешнейОбработки = ДополнительныеОтчетыИОбработкиВызовСервера.ПодключитьВнешнююОбработку(ВнешнийОтчетСсылка);
     
    Функция ПолучитьСсылкуНаВнешнийОтчетПоИмениНаСервере(ИмяОтчета) Экспорт
        Возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяОтчета).Ссылка;
    КонецФункции
[А что Если… КонецЕсли]
1 пользователей читают эту тему (1 гостей и 0 скрытых пользователей)
0 пользователей:


Рейтинг@Mail.ru
[ Script Execution time: 0,0796 ]   [ 19 queries used ]   [ Generated: 29.03.20, 08:46 GMT ]