На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
! Дополнения к правилам (только для данного раздела)
- Используйте подсветку синтаксиса при выделении исходного кода;
- В описании темы обязательно укажите язык программирования;
- Прежде чем задать вопрос, обязательно воспользуйтесь поиском и загляните в FAQ раздела.
- Если вопрос касается серверного ПО, указывайте ОС.
- Если вопрос касается ASP.NET то лучше будет задать его в соответствующем разделе. Там вы сможете получить ответ намного быстрее.

Модераторы: Serafim, fatalist
Страницы: (2) [1] 2  все  ( Перейти к последнему сообщению )  
> не срабатывает правило mod_rewrite
    Ситуация такая: в каталоге C:\usr\home\ptoj.ru\www лежит .htaccess с таким содержанием
    ExpandedWrap disabled
      RewriteEngine On
       
      RewriteRule ^(.*/testing3/.*) - [L]
       
      RewriteCond %{REQUEST_FILENAME} !global.php$
      RewriteRule ^(.*)$ /site/global.php?page=/$1 [L]

    который должен перенаправлять запросы на скрипт global.php, однако этого не происходит.

    В httpd.conf DocumentRoot указан такой: "C:\usr\home\proj.ru".
      Цитата WalterScott @
      RewriteCond %{REQUEST_FILENAME} !.*global.php$
      ?
        Если $_SERVER['REQUEST_FILENAME'] не равно "любая строкаglobal.php" то выполняется следующий RewriteRule.
        Разве не так?
          :o Сорри, ночью лучше спать :(

          Я подумал, ты спрашиваешь, что означает эта строчка(тем более, тогда уж $_SERVER['REQUEST_URI']).

          Но и так не работает. По моему тут дело не в содержимом .htaccess, а в чём то другом.


          Строка LoadModule rewrite_module modules/mod_rewrite.so в httpd.conf раскомментирована.
            что говорит RewriteLog?
              Вот он у меня где
              ExpandedWrap disabled
                RewriteLog /usr/local/apache/apache2/logs/mod_rewrite.log


              Ничего не говорит, пусто.
                теряюсь в догадках...
                1. а выложи-ка свой httpd.conf
                2. как выглядит твой запрос серверу?
                3. что ты хочешь получить? (вопрос, впринципе, риторический...)
                  В понедельник выложу httpd.conf.
                    1. Конфиг прикрепил.
                    2. http://localhost
                    3. Вместо страницы index.html, которую я вижу сейчас, я хочу получить результат работы global.php
                    Прикреплённый файлПрикреплённый файлhttpd.conf.doc (122 Кбайт, скачиваний: 215)
                      при беглом просмотре у тебя указан DocumentRoot "C:\usr\home\tisbi.ru"
                      а, как ты сказал, .htaccess лежит в "C:\usr\home\ptoj.ru\www"
                      если это так, то вполне логично, что не работает

                      зы: и зачем конфиг в .doc выкладывать?
                        Цитата negram @
                        а, как ты сказал, .htaccess лежит в "C:\usr\home\ptoj.ru\www"

                        Это так сказать, в общем виде...

                        .htaccess лежит в C:\usr\home\tisbi.ru\www

                        Цитата negram @
                        и зачем конфиг в .doc выкладывать?
                        С оригинальным расширением я его не смог выложить - пишет, что такой файлы такого формата не допускаются, даже если сохранить как .txt всё равно не пропускает.
                          Цитата WalterScott @
                          .htaccess лежит в C:\usr\home\tisbi.ru\www

                          а как сервер поймёт, что его надо читать, если корневая папка, у тебя, на уровень выше?
                          обращение, ведь, идёт к C:\usr\home\tisbi.ru
                            Да, логично. Но когда я копирую всё содержимое www включая .htaccess в C:\usr\home\tisbi.ru, ничего не меняется. Сервер, конечно , перезапускаю при этом.
                              получил, при запуске "[Mon May 28 12:19:37 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts" :-/
                              а ошибка была в том, что .htaccess не обрабатывался из-за директивы
                              ExpandedWrap disabled
                                <Directory />
                                    Options FollowSymLinks
                                    AllowOverride None # !!!
                                </Directory>

                              добавь такую секцию:
                              ExpandedWrap disabled
                                <directory "C:\usr\home\tisbi.ru">
                                    AllowOverride All
                                </directory>
                              и будет вам счастье! :)
                              хинт: http://httpd.apache.org/docs/2.0/ru/mod/core.html#allowoverride
                                Да, так оно и есть, спасибо!
                                1 пользователей читают эту тему (1 гостей и 0 скрытых пользователей)
                                0 пользователей:


                                Рейтинг@Mail.ru
                                [ Script Execution time: 0,1834 ]   [ 14 queries used ]   [ Generated: 18.02.20, 09:00 GMT ]