На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
! Правила раздела:

  • Перед тем, как задать вопрос, желательно почитать документацию и воспользоваться поиском.
  • Когда задаёте вопрос, то обязательно указывайте платформу (7.7, 8.0, 8.1, 8.2, etc), причем желательно в заголовке. Если речь идёт о типовой конфигурации, то указывайте её название и релиз. Текущие версии можно посмотреть здесь.
  • Ещё раз напоминаем о необходимости соблюдать не только правила, но и законы. Уважайте авторские права.

Высказать своё мнение о модераторах раздела можно здесь: evGenius
Модераторы: evGenius
  
> Поиск таблицы 1C в базе SQL, странная ситуация
    И снова здравствуйте!

    Понадобилось мне найти справочник Номенклатура в базе SQL (Все та же горячо любимая ERP). С помощью
    ExpandedWrap disabled
      ПолучитьСтруктуруХраненияБазыДанных()

    получил что в SQL базе таблица называется _Reference231.
    Пишу прямой запрос к базе
    ExpandedWrap disabled
      SELECT * FROM [ERP].[dbo].[_Reference231]

    Выбрано 0 строк.
    Недолго втыкаю, думаю что ошибся в имени справочника, перепроверяю - нет, все верно.
    После 10 минут убеждения себя что я не ошибся в имени справочника, запускаю Profiler и отлавливаю что обращение идет к таблице _Reference231X1!
    Но этой таблицы нет в том что мне вернула функция ПолучитьСтруктуруХраненияБазыДанных()!!! А вот в дереве таблиц MS SQL Server Management Studio табличка есть. И справочник номенклатуры хранится именно в этой таблице.

    И как это понимать?

    P.S. Возможно дело в механизме хранения данных SQL сервером, либо в тонкостях взаимодействия сервера 1С и SQL. Кто-нибудь может объяснить почему так? Ну или хотя бы ссылкой кинуть где почитать. А то я даже вопрос не знаю как сформулировать, чтобы у гугла спросить.
    [А что Если… КонецЕсли]
      Выясни, что это за об’ект: select * from sysobjects (м. б. Sys.objects)
      Думаю, что _reference231 - это view со внутренним фильтром пользователя или udf с параметром по умолчанию.
      Мои религиозные убеждения не позволяют мне комментировать код.
      Моё мировоззренье таково: в программе комментария ни одного!
        Цитата MIF @
        Выясни, что это за об’ект

        Пользовательская таблица, как и _Reference231
        Скриншот результата запроса
        Сообщение отредактировано: Rust -
        [А что Если… КонецЕсли]
          Rust
          Расширение конфигурации может быть?
          "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
            Цитата ^D^ima @
            Расширение конфигурации может быть?

            Точно! Почему-то не подумал про расширение. Кто-то добавил один реквизит справочнику номенклатуры в расширении, видимо не хотели включать возможность изменения.
            Интересно почему не стали использовать доп реквизиты, но это уже из другой песни.

            Добавлено
            Спасибо всем, вопрос решен.
            Сообщение отредактировано: Rust -
            [А что Если… КонецЕсли]
            0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
            0 пользователей:


            Рейтинг@Mail.ru
            [ Script Execution time: 0,1052 ]   [ 17 queries used ]   [ Generated: 22.02.20, 20:17 GMT ]