На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное DigiMania RSS
msm.ru
! Этот раздел предназначен для заполнения/проверки/рехтования/* содержимого будущего FAQ и не более того.
Все вопросы касательно 1С следует задавать здесь: 1С: Проблемы и решения
Модераторы: evGenius
Страницы: (4) « Первая ... 2 3 [4]  все  ( Перейти к последнему сообщению )  
> вопросы -ответы №3, format complete, осталось проверить и расфасовать
    Как организовать работу с индикатором?
    ExpandedWrap disabled
      Выборка = РезультатЗапроса.Выбрать();
      Индикатор = ЭлементыФормы.ИндикаторПеребора;
      Индикатор.МаксимальноеЗначение = Выборка.Количество();
      Индикатор.Значение = 0;
       
      Пока Выборка.Следующий() Цикл
              Индикатор.Значение = Индикатор.Значение + 1;
      КонецЦикла;
       
      Выборка = РезультатЗапроса.Выбрать();
      Индикатор = ЭлементыФормы.ИндикаторПеребора;
      Индикатор.МаксимальноеЗначение = Выборка.Количество();
      Индикатор.Значение = 0;
      Индикатор.ОтображатьПроценты = Истина;
      Индикатор.СтильОтображения = РежимСглаживанияИндикатора.Прерывистый;
      Индикатор.Ориентация = Ориентация.Вертикально;
      Индикатор.Шаг = 0.1;
       
      Пока Выборка.Следующий() Цикл
              Индикатор.Значение = Индикатор.Значение + 1;
      КонецЦикла;
      Как у элемента управления сменить источник данных?
      ExpandedWrap disabled
        Процедура КнопкаВыполнитьНажатие(Элемент)
         
                ЭлементыФормы.ТП.Данные = "СписокКонтрагентов";
                ЭлементыФормы.ТП.СоздатьКолонки();
         
        КонецПроцедуры
         
        Процедура Номенклатура(Кнопка)
         
                ЭлементыФормы.ТП.Данные = "СписокНоменклатуры";
                ЭлементыФормы.ТП.СоздатьКолонки();
         
        КонецПроцедуры
        Как задать представление даты, отображаемое в поле ввода по-умолчанию?

        ЭлементыФормы.ПолеВвода1.Формат = "ДП='01.01.0001'";

        ЭлементыФормы.ПолеВвода1.Формат = "ДП='00:00:00'";

        ЭлементыФормы.ПолеВвода1.Формат = "ДП='01.01.0001 00:00:00'";
          Как вывести текст в поле картинки в том случае, если картинка не выбрана?
          ExpandedWrap disabled
            ЭлементыФормы.ОсновноеИзображение.ТекстНевыбраннойКартинки = "фотография номенклатуры отсутствует";
            Как открыть пользователю стандартный диалог выбора цвета?
            ExpandedWrap disabled
              Диалог = Новый ДиалогВыбораЦвета;
              Если Диалог.Выбрать() Тогда
                      ВыбранныйЦвет = Диалог.Цвет;
              КонецЕсли;
              Диалог = Новый ДиалогВыбораШрифта;
              Если Диалог.Выбрать() Тогда
                      ВыбранныйШрифт = Диалог.Шрифт;
              КонецЕсли;
              Как заполнить список в форме данными запроса?
              ExpandedWrap disabled
                Запрос = Новый Запрос("
                |ВЫБРАТЬ
                |       Номенклатура.Ссылка КАК Значение,
                |       Номенклатура.Представление КАК Представление,
                |       ИСТИНА КАК Пометка
                |ИЗ
                |       Справочник.Номенклатура КАК Номенклатура
                |ГДЕ
                |       Номенклатура.ОсновнойПоставщик = &ОсновнойПоставщик");
                 
                Запрос.УстановитьПараметр("ОсновнойПоставщик", ПолеПоставщик);
                 
                Выборка = Запрос.Выполнить().Выбрать();
                 
                Пока Выборка.Следующий() Цикл
                        ЗаполнитьЗначенияСвойств(ПолеСписка.Добавить(), Выборка);
                КонецЦикла;
                Как отобразить в форме файл графической схемы?
                ExpandedWrap disabled
                  Схема = Новый ГрафическаяСхема();
                  Схема.Прочитать("D:/MyScheme.grs");
                  ЭлементыФормы.СтруктурнаяСхема.УстановитьСхему(Схема);
                1 пользователей читают эту тему (1 гостей и 0 скрытых пользователей)
                0 пользователей:


                Рейтинг@Mail.ru
                [ Script Execution time: 0,0908 ]   [ 15 queries used ]   [ Generated: 18.11.19, 06:08 GMT ]