На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное DigiMania RSS
msm.ru
! Этот раздел предназначен для заполнения/проверки/рехтования/* содержимого будущего FAQ и не более того.
Все вопросы касательно 1С следует задавать здесь: 1С: Проблемы и решения
Модераторы: evGenius
Страницы: (4) 1 [2] 3 4  все  ( Перейти к последнему сообщению )  
> вопросы -ответы №3, format complete, осталось проверить и расфасовать
    Как открыть форму внешней обработки?
    ExpandedWrap disabled
      Обработка = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
      Обработка.Открыть();
       
      //либо так:
      Обработка = ВнешниеОбработки.ПолучитьФорму("C:\Внешние\СпецОтчет.epf", ИмяФормы, , Ключ);
      Обработка.Открыть();
      Как отрыть форму отчета так, чтобы она не перекрывала собой ту форму, из которой она открыта?
      ExpandedWrap disabled
        Форма = Отчеты.ОтчетДиаграмма.ПолучитьФорму("ФормаОсновная", ЭтаФорма);
        Форма.ПоложениеОкна = ВариантПоложенияОкна.НеПерекрыватьВладельца;
        Форма.Открыть();
        Как открыть форму отчета на весь экран?
        ExpandedWrap disabled
          СпособОтображенияОкна = ВариантСпособаОтображенияОкна.Максимизированное;
          ИзмененятьСпособОтображенияОкна = ИзменениеСпособаОтображенияОкна.Запретить;
          Как из формы документа открыть форму списка данного документа, спозиционировавшись на нем же?
          ФормаСписка = Документы[Метаданные().Имя].ПолучитьФормуСписка();
          ФормаСписка.ПараметрТекущаяСтрока = Ссылка;
          ФормаСписка.Открыть();
          ФормаСписка = Документы[Метаданные().Имя].ПолучитьФормуСписка( , , Новый УникальныйИдентификатор());
          В документе есть реквизит "Контрагент". Как открыть форму подчиненного ему справочника "ДоговорыКонтрагентов"?
          ExpandedWrap disabled
            Если Не Контрагент.Пустая() Тогда
                    ФормаПодчиненныхДоговоров = Справочники.ДоговорыКонтрагентов.ПолучитьФормуСписка();
                    ФормаПодчиненныхДоговоров.ПараметрОтборПоВладельцу = Контрагент;
                    ФормаПодчиненныхДоговоров.Открыть();
            КонецЕсли;
            Как в форме отобразить картинку, сохраненную в реквизите справочника?
            ExpandedWrap disabled
              // Значение, сохраненное в реквизите справочника, имеющем тип
              // ХранилищеЗначения, можно только получить.
              СохраненнаяКартинка = Фотография.Получить();
               
              Если СохраненнаяКартинка <> Неопределено Тогда
                       // Если в хранилище было что-нибудь заранее записано…
                      ЭлементыФормы.Фото.Картинка = СохраненнаяКартинка;
              КонецЕсли;
              Как в журнале документов "УчетКадров" отобрать только документы "ПриемНаРаботу"?
              ExpandedWrap disabled
                ЖурналДокументовСписок.Отбор.ВидДокумента.Установить(Метаданные.Документы.ПриемНаРаботу);
                Как узнать интервал дат в открытом текущем журнале?
                ExpandedWrap disabled
                  Если ЖурналДокументовСписок.Отбор.Дата.Использование Тогда
                          Сообщить(ЖурналДокументовСписок.Отбор.Дата);
                   
                  Иначе
                          Сообщить("Без ограничения по датам");
                  КонецЕсли;
                  Как при открытии справочника сделать отбор по контрагентам, входящим в список?
                  ExpandedWrap disabled
                    Процедура ПриОткрытии()
                            СправочникСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
                            СправочникСписок.Отбор.Ссылка.Значение = СписокКонтрагентов;
                            СправочникСписок.Отбор.Ссылка.Использование = Истина;
                     КонецПроцедуры
                    Как обеспечить, чтобы для выбора значения покупателя в расходной накладной справочник контрагенты открывался сразу с открытой группой "Покупатели"?
                    ExpandedWrap disabled
                      Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка)
                       
                              Если Элемент.Значение.Пустая() Тогда
                                     СтандартнаяОбработка = Ложь;
                                     ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора( , Элемент);
                                     ФормаВыбора.ВыборПокупателя = Истина;
                                     ФормаВыбора.Открыть();
                              КонецЕсли;
                       
                      КонецПроцедуры
                       
                      Если ВыборПокупателя Тогда
                              ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
                              ЭлементыФормы.СправочникСписок.ТекущийРодитель = Константы.ГруппаПокупатели.Получить();
                      КонецЕсли;
                       
                      Если ВыборПокупателя Тогда
                              ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
                              ЭлементыФормы.СправочникСписок.ТекущийРодитель = Справочники.Контрагенты.Покупатели;
                      КонецЕсли;
                      Табличное поле
                      Как запретить пользователю изменять порядок следования колонок в табличном поле?
                      ExpandedWrap disabled
                        ЭлементыФормы.ТабличноеПоле.ИзменятьПозициюКолонок = Ложь;
                        ЭлементыФормы.ТабличноеПоле.Колонки.Картинка.ИзменятьПозицию = Ложь;
                        ЭлементыФормы.ТабличноеПоле.Колонки.Код.ИзменятьПозицию = Ложь;
                        ЭлементыФормы.ТабличноеПоле.Колонки.Наименование.ИзменятьПозицию = Ложь;
                        Как запретить пользователю изменять любые настройки колонок табличного поля?
                        ExpandedWrap disabled
                          ЭлементыФормы.ТабличноеПоле.ИзменятьНастройкуКолонок = Ложь;
                          ЭлементыФормы.ТабличноеПоле.Колонки.Картинка.ИзменятьНастройку = Ложь;
                          ЭлементыФормы.ТабличноеПоле.Колонки.Код.ИзменятьНастройку = Ложь;
                          ЭлементыФормы.ТабличноеПоле.Колонки.Наименование.ИзменятьНастройку = Ложь;
                          Как вывести информацию о том, какой отбор установлен в журнале документов?
                          ExpandedWrap disabled
                            ЭлементыФормы.НадписьОтбор.Заголовок = СписокДокументов.Отбор;
                            УстановленныйОтбор = СписокДокументов.Отбор;
                            Сообщить("Элементы отбора:");
                             
                            Для Каждого ЭлементОтбора из УстановленныйОтбор Цикл
                                    Сообщить(Строка(ЭлементОтбора) + " использование = " + ЭлементОтбора.Использование);
                            КонецЦикла;
                            Как в форме справочника установить курсор на элемент с известным наименованием?
                            ExpandedWrap disabled
                              ЭлементыФормы.СправочникСписок.ТекущаяСтрока = Справочники.Контрагенты.НайтиПоНаименованию("ПОСТАВЩИКИ", Истина);
                              Как в форме списка сделать отбор по значению реквизита?
                              ExpandedWrap disabled
                                 СправочникСписок.Отбор.СтавкаНДС.Установить(Перечисления.СтавкиНДС.НДС18);
                                 
                                СправочникСписок.Отбор.СтавкаНДС.Значение = Перечисления.СтавкиНДС.НДС18;
                                СправочникСписок.Отбор.СтавкаНДС.ВидСравнения = ВидСравнения.Равно;
                                СправочникСписок.Отбор.СтавкаНДС.Использование = Истина;
                                Как запретить выдачу сообщения: "Введенные данные не отображены в списке, так как не соответствуют отбору" при добавлении новых элементов в справочник?
                                ExpandedWrap disabled
                                  ЭлементыФормы.ПолеСписка.ПроверкаОтображенияНовойСтроки = ВариантПроверкиОтображенияНовойСтроки.НеПроверять;
                                0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                                0 пользователей:
                                Страницы: (4) 1 [2] 3 4  все


                                Рейтинг@Mail.ru
                                [ Script Execution time: 0,1523 ]   [ 18 queries used ]   [ Generated: 19.11.19, 15:17 GMT ]