На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное DigiMania RSS
msm.ru
Модераторы: PIL
  
> Проигрывание swf на сайте
    Салют всем! Я не занимаюсь Flash-технологиями, меня интересует вопрос: размещённый на сайте ролик swf после загрузки начинает проигрываться сразу самим Flash-плеером или в ролике присутствуют команда старта проигрывания и может ли ролик запускаться внешними командами в HTML-коде? Т.е. первый кадр отображается, а остальные начинают отображаться по какой команде?
    Сообщение отредактировано: BlackSun -
      Ролик запускается сам, но контент можно сделать так чтобы была возможность паузы в начале. Внутренним содержимым можно управлять извне: хттп запросами, через сокеты, другим флеш роликом, жабаскриптом.
        Я разместил флешку на конструкторе сайтов и она проигрывается сразу после загрузки. А мне надо чтобы она не проигрывалась, править я её не могу, разве что в HEX-редакторе. Вот код со страницы сайта:

        ExpandedWrap disabled
          <object style="visibility: visible;" data="..._files/123.swf" type="application/x-shockwave-flash" id="comp-ijtykg3zflashContainer" align="middle" height="100%" width="100%">
          <param value="high" name="quality">
          <param value="#FAFAFA" name="bgcolor">
          <param value="never" name="allowscriptaccess">
          <param value="true" name="allowfullscreen">
          <param value="transparent" name="wMode">
          <param value="exactFit" name="scale">
          <param value="" name="flashVars">
          <param value="true" name="play">
          <param value="true" name="autoplay">
          </object>


        Я так понимаю, во всём виновата строка <param value="true" name="autoplay">? И что тогда делает <param value="true" name="play">?
        Сообщение отредактировано: BlackSun -
          C <param value="true" name="play"> разобрался. С <param value="true" name="autoplay"> не ясно, вкл./откл. этой строки ничего не даёт.

          Добавлено
          Сам swf был создан программой CamStudio 2.7 - скрин с экрана (размер файла 12Мб, в формате avi 150Мб). При импорте ролика в FlashMX идёт долгая загрузка, потом при проигрывании нет звука. При попытке сохранить ролик опять в swf FlashMX долго обрабатывает, потом вылетает ошибка о нехватке памяти - каждый кадр ключевой и похоже, каждый кадр идёт как растровое изображение. Поэтому не могу ролик поправить и сохранить, при просмотре на локал. странице на первом кадре надпись "Loading..." и, если ролик не проигрывается сразу <param value="false" name="play"> - надпись висит статично, процесс загрузки не отображается.
          Сообщение отредактировано: BlackSun -
          0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
          0 пользователей:


          Рейтинг@Mail.ru
          [ Script Execution time: 0,0953 ]   [ 17 queries used ]   [ Generated: 15.11.18, 08:48 GMT ]