На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное DigiMania RSS
msm.ru
! Правила раздела:

  • Перед тем, как задать вопрос, желательно почитать документацию и воспользоваться поиском.
  • Когда задаёте вопрос, то обязательно указывайте платформу (7.7, 8.0, 8.1, 8.2, etc), причем желательно в заголовке. Если речь идёт о типовой конфигурации, то указывайте её название и релиз. Текущие версии можно посмотреть здесь.
  • Ещё раз напоминаем о необходимости соблюдать не только правила, но и законы. Уважайте авторские права.

Высказать своё мнение о модераторах раздела можно здесь: evGenius
Модераторы: evGenius
Страницы: (2) [1] 2  все  ( Перейти к последнему сообщению )  
> Размер таблиц ИБ
    Раньше для просмотра размера таблиц пользовался Tool_1CD.exe, но он последние версии файлов 1CD уже не поддерживает.

    Какими инструментами можно это посмотреть? Желательно внешняя программа.
    "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
      С внешними проблема, обработки есть.
        evGenius
        Можно скинуть?

        Ещё абстрактный вопрос:
        Есть универсальный загрузчик документов например из таблиц?

        Т.е. выбрали входящую таблицу, тип документа на выходе. проставили соответствия полей и выполнили импорт.
        "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
          Прикреплённый файлПрикреплённый файл______________________________________________________________________.zip (54,91 Кбайт, скачиваний: 38)
          Лови.
            Спасибо он только для справочников и подобных вещей, не для документов.
            "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
              Кстати у меня есть более новый:
              Прикреплённый файлПрикреплённый файлuploadfromtabledocument.zip (57,13 Кбайт, скачиваний: 35)
              "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                Цитата ^D^ima @
                Можно скинуть?

                Вроде бы эта, проверь.
                Прикреплённый файлПрикреплённый файлTablesSizes.rar (543,3 Кбайт, скачиваний: 40)
                  у тебя какой ToolCD версии? не понял про обработку загрузку данных из табличной части...
                  Сообщение отредактировано: alevi -
                    Цитата alevi @
                    у тебя какой ToolCD версии?

                    Tool_1CD_0_3_0
                    "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                      Ничего не работает на новой версии базы. Есть свежие обработки для определения размера базы?
                      "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                        Цитата ^D^ima @
                        Ничего не работает на новой версии базы.

                        Есть такая утилита cnvdbfl.exe, лежит обычно в каталоге bin твоей версии платформы.
                        В cmd набираешь

                        ExpandedWrap disabled
                          cnvdbfl.exe -c -f 8.2.14 D:\<Путь к базе, ну ты понял>\1Cv8.1CD


                        База переводится в формат 8.2.14 Смотришь все что надо в Tool_1CD.
                        Естественно, нужно делать на копии. В процессе могут быть ошибки, забей на них, обычно все переводится.
                        [А что Если… КонецЕсли]
                          Жаль. А что такого в новой версии что нет ни одной обработки?
                          "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                            Начиная с 8.3.8 оптимизировали структуру базы для улучшения скорости и стабильности при реструктуризации и работе. Подробности можно нарыть в интернете или на сайте ИТС. Я внимательно не вчитывался. Насколько я понял автора Tool_1CD больше с нами нет. Поэтому и доработать утилиту некому, как и некоторые другие обработки автора, к очень большому сожалению.
                            [А что Если… КонецЕсли]
                              Цитата Rust @
                              Tool_1CD

                              На программе свет клином не сошелся. Гугление даже инфостарте не дает результата, авторы других обработок пишут что не будут делать под новый формат, х.з. почему.

                              Добавлено
                              Цитата Rust @
                              cnvdbfl.exe -c -f 8.2.14 D:\<Путь к базе, ну ты понял>\1Cv8.1CD

                              пилять :wall:
                              ExpandedWrap disabled
                                cnvdbfl.exe -c -f 8.2.14 "C:\Test base\1С БУХ Рабочая\1Cv8.1CD"
                                Превышен максимально допустимый размер внутреннего файла 'C:\Test base\1С БУХ Рабочая\_$NEW$_.1CD'

                              База 15 Гб, _$NEW$_.1CD - 5,8 гб.

                              Какие ещё будут предложения?
                              "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                                Цитата ^D^ima @
                                База 15 Гб

                                :blink: Файловая ???
                                Все что переваливает за 4 гига я обычно перевожу на MS SQL. Да, перевод стоит денег, но зато намного стабильнее все работает.
                                Цитата ^D^ima @
                                Какие ещё будут предложения?

                                используете вложения файлов? если да - чисти вложения. Еще Кладр(ФИАС) занимает дофея места.
                                Если все не помогает - делай свертку базы.

                                Кстати да, не с того начал советовать, с какой целью то нужно посмотреть размеры таблиц?
                                [А что Если… КонецЕсли]
                                0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                                0 пользователей:


                                Рейтинг@Mail.ru
                                [ Script Execution time: 0,1481 ]   [ 23 queries used ]   [ Generated: 23.10.19, 23:21 GMT ]