На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
! Этот раздел предназначен для заполнения/проверки/рехтования/* содержимого будущего FAQ и не более того.
Все вопросы касательно 1С следует задавать здесь: 1С: Проблемы и решения
Модераторы: evGenius
  
> вопросы -ответы №3, format complete, осталось проверить и расфасовать
    Документация 1с 8.х
    ExpandedWrap disabled
      // Добавить новый вид характеристик.
      Если ВидМенеджеры.Пустая() Тогда
          ВидМенеджеры = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СоздатьЭлемент();
          ВидМенеджеры.Наименование = "Менеджеры";
          ВидМенеджеры.ТипЗначения = Новый ОписаниеТипов("СправочникСсылка.Пользователи");
          ВидМенеджеры.Записать();
      КонецЕсли;
       
      // Получить нужный счет.
      Счет = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
      Если (Не Счет.Пустая()) И (Счет.ВидыСубконто.Найти(ВидМенеджеры) = Неопределено) Тогда
       
              // Добавить новый вид субконто к счету.
              ОбъектСчета = Счет.ПолучитьОбъект();
              НовыйВидСубконто = ОбъектСчета.ВидыСубконто.Добавить();
              НовыйВидСубконто.ВидСубконто = ВидМенеджеры;
              НовыйВидСубконто.ТолькоОбороты = Истина;
              НовыйВидСубконто.Суммовой = Истина;
              
              ОбъектСчета.Записать();
      КонецЕсли;
    Сообщение отредактировано: Artega -
      Как из регистра бухгалтерии "Хозрасчетный" получить обороты только по валютным счетам?
      ExpandedWrap disabled
        ВЫБРАТЬ
            ХозрасчетныйОбороты.Организация КАК Организация,
            ХозрасчетныйОбороты.Счет КАК Счет,
            ХозрасчетныйОбороты.Валюта,
            ХозрасчетныйОбороты.СуммаОборотДт,
            ХозрасчетныйОбороты.ВалютнаяСуммаОборотДт,
            ХозрасчетныйОбороты.СуммаОборотКт,
            ХозрасчетныйОбороты.ВалютнаяСуммаОборотКт
        ИЗ
            РегистрБухгалтерии.Хозрасчетный.Обороты(&ДатаНач, &ДатаКон, , Счет.Валютный, , , , ) КАК ХозрасчетныйОбороты
        УПОРЯДОЧИТЬ ПО
            Организация,
            ХозрасчетныйОбороты.Счет.Код
        Как выбрать в регистре бухгалтерии "Хозрасчетный" обороты по "60-ым" счетам, исключив внутренние обороты между ними?
        ExpandedWrap disabled
          ВЫБРАТЬ
              ХозрасчетныйОбороты.Счет,
              ХозрасчетныйОбороты.СуммаОборотДт,
              ХозрасчетныйОбороты.СуммаОборотКт
          ИЗ
              РегистрБухгалтерии.Хозрасчетный.Обороты(&ДатаНач, &ДатаКон , , Счет В ИЕРАРХИИ (&Счет), , , НЕ(КорСчет В ИЕРАРХИИ (&Счет)), ) КАК ХозрасчетныйОбороты
          УПОРЯДОЧИТЬ ПО
              ХозрасчетныйОбороты.Счет.Код
          Как реализовать метод "красного сторно" для регистра бухгалтерии?
          ExpandedWrap disabled
            Процедура ОбработкаПроведения(Отказ, Режим)
             
                    СторнируемыеДвижения = РегистрыБухгалтерии.Хозрасчетный.ВыбратьПоРегистратору(СторнируемыйДокумент);
                    
                    Пока СторнируемыеДвижения.Следующий() Цикл
                           Проводка = Движения.Хозрасчетный.Добавить();
                           Проводка.Период = Дата;
                           Проводка.СчетДт = СторнируемыеДвижения.СчетДт;
                           Проводка.СчетКт = СторнируемыеДвижения.СчетКт;
             
                           Для каждого Субконто Из СторнируемыеДвижения.СубконтоДт Цикл
                                   Проводка.СубконтоДт[Субконто.Ключ] = Субконто.Значение;
                           КонецЦикла;
             
                           Для каждого Субконто Из СторнируемыеДвижения.СубконтоКт Цикл
                                   Проводка.СубконтоКт[Субконто.Ключ] = Субконто.Значение;
                           КонецЦикла;
             
                           Проводка.ВалютаДт = СторнируемыеДвижения.ВалютаДт;
                           Проводка.ВалютаКт = СторнируемыеДвижения.ВалютаКт;
                           Проводка.ВалютнаяСуммаДт = - СторнируемыеДвижения.ВалютнаяСуммаДт;
                           Проводка.ВалютнаяСуммаКт = - СторнируемыеДвижения.ВалютнаяСуммаКт;
                           Проводка.КоличествоДт = - СторнируемыеДвижения.КоличествоДт;
                           Проводка.КоличествоКт = - СторнируемыеДвижения.КоличествоКт;
                           Проводка.НомерЖурнала = СторнируемыеДвижения.НомерЖурнала;
                           Проводка.Организация = СторнируемыеДвижения.Организация;
                           Проводка.Содержание = СторнируемыеДвижения.Содержание;
                           Проводка.Сумма = - СторнируемыеДвижения.Сумма;
                    КонецЦикла;
             
                    Движения.Хозрасчетный.Записать();
             
            КонецПроцедуры
            Сложные периодические расчеты
            Как получить сумму начисления по конкретному виду расчета указанному сотруднику в указанном периоде?
            ExpandedWrap disabled
              Запрос = Новый Запрос;
              Запрос.Текст = "ВЫБРАТЬ
              |    БУОсновныеНачисления.Результат
              |ИЗ
              |    РегистрРасчета.БУОсновныеНачисления КАК БУОсновныеНачисления
              |ГДЕ
              |    БУОсновныеНачисления.ПериодРегистрации = &Период
              |    И
              |    БУОсновныеНачисления.ФизЛицо = &ФизЛицо
              |    И
              |    БУОсновныеНачисления.ВидРасчета = &ВидРасчета";
               
              Запрос.УстановитьПараметр("Период", НачалоМесяца(Период1));
              Запрос.УстановитьПараметр("ВидРасчета", ВидРасчета);
              Запрос.УстановитьПараметр("ФизЛицо", ФизЛицо);
              Как получить сумму всех начислений указанному сотруднику в указанном периоде?
              ExpandedWrap disabled
                ВЫБРАТЬ
                |       БУОсновныеНачисления.Организация КАК Организация,
                |       ПРЕДСТАВЛЕНИЕ(БУОсновныеНачисления.Организация),
                |       БУОсновныеНачисления.ВидРасчета,
                |       ПРЕДСТАВЛЕНИЕ(БУОсновныеНачисления.ВидРасчета),
                |       БУОсновныеНачисления.Результат КАК Результат,
                |       ""Основные"" КАК ВариантНачислений
                |ИЗ
                |       РегистрРасчета.БУОсновныеНачисления КАК БУОсновныеНачисления
                |ГДЕ
                |       БУОсновныеНачисления.ПериодРегистрации = &НужныйПериод И БУОсновныеНачисления.ФизЛицо = &ФизЛицо
                |
                |ОБЪЕДИНИТЬ ВСЕ
                |
                |ВЫБРАТЬ
                |       БУДополнительныеНачисления.Организация,
                |       ПРЕДСТАВЛЕНИЕ(БУДополнительныеНачисления.Организация),
                |       БУДополнительныеНачисления.ВидРасчета,
                |       ПРЕДСТАВЛЕНИЕ(БУДополнительныеНачисления.ВидРасчета),
                |       БУДополнительныеНачисления.Результат,
                |       ""Дополнительные""
                |ИЗ
                |       РегистрРасчета.БУДополнительныеНачисления КАК БУДополнительныеНачисления
                |ГДЕ
                |       БУДополнительныеНачисления.ПериодРегистрации = &НужныйПериод И БУДополнительныеНачисления.ФизЛицо = &ФизЛицо
                |ИТОГИ СУММА(Результат)
                |ПО ОБЩИЕ, Организация, ВариантНачислений";
                Как получить таблицу перерасчетов по перерасчетам нескольких регистров?
                ExpandedWrap disabled
                  ВЫБРАТЬ
                      ПерерасчетОсновных.ФизЛицо КАК Работник,
                      ПерерасчетОсновных.ВидРасчета,
                      ПерерасчетОсновных.ОбъектПерерасчета КАК Документ
                  ИЗ
                      РегистрРасчета.ОсновныеНачисленияРаботниковОрганизации.ПерерасчетОсновныхНачислений КАК ПерерасчетОсновных
                   
                  ОБЪЕДИНИТЬ ВСЕ
                   
                  ВЫБРАТЬ
                      ПерерасчетДополнительных.ФизЛицо,
                      ПерерасчетДополнительных.ВидРасчета,
                      ПерерасчетДополнительных.ОбъектПерерасчета
                  ИЗ
                      РегистрРасчета.ДополнительныеНачисленияРаботниковОрганизации.ПерерасчетДополнительныхНачислений КАК ПерерасчетДополнительных
                  Как для документа "НачислениеЗарплатыРаботникам" определить номера строк записей полностью вытесненных видов расчета?
                  ExpandedWrap disabled
                    ВЫБРАТЬ РАЗРЕШЕННЫЕ
                        УправленческиеНачисления.НомерСтроки КАК НомерСтроки
                    ИЗ
                        РегистрРасчета.УправленческиеНачисления КАК УправленческиеНачисления
                        ЛЕВОЕ СОЕДИНЕНИЕ
                            РегистрРасчета.УправленческиеНачисления.ФактическийПериодДействия(Регистратор = &парамСсылка) КАК УправленческиеНачисленияФактическийПериодДействия
                        ПО
                            УправленческиеНачисления.НомерСтроки = УправленческиеНачисленияФактическийПериодДействия.НомерСтроки
                            И
                            УправленческиеНачисления.Регистратор = УправленческиеНачисленияФактическийПериодДействия.Регистратор
                    ГДЕ
                        УправленческиеНачисления.Регистратор = &парамСсылка
                        И
                        ((УправленческиеНачисленияФактическийПериодДействия.Регистратор) ЕСТЬ NULL)
                    Как сформировать расчетный листок сотрудника?
                    ExpandedWrap disabled
                      "ВЫБРАТЬ
                      |    ВложенныйЗапрос.ФизЛицо,
                      |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ФизЛицо),
                      |    ВложенныйЗапрос.ФизЛицоПредставление КАК ФизЛицоПредставление1,
                      |    ВложенныйЗапрос.ВидРасчета,
                      |    ПРЕДСТАВЛЕНИЕ(ВложенныйЗапрос.ВидРасчета),
                      |    ВложенныйЗапрос.ВидРасчетаПредставление КАК ВидРасчетаПредставление1,
                      |    ВложенныйЗапрос.Результат КАК Результат,
                      |    ВложенныйЗапрос.ТипРасчета КАК ТипРасчета
                      |ИЗ
                      |    (ВЫБРАТЬ
                      |        БУОсновныеНачисления.ФизЛицо КАК ФизЛицо,
                      |        ПРЕДСТАВЛЕНИЕ(БУОсновныеНачисления.ФизЛицо) КАК ФизЛицоПредставление,
                      |        БУОсновныеНачисления.ВидРасчета КАК ВидРасчета,
                      |        ПРЕДСТАВЛЕНИЕ(БУОсновныеНачисления.ВидРасчета) КАК ВидРасчетаПредставление,
                      |        БУОсновныеНачисления.Результат КАК Результат,
                      |        ""Начисления"" КАК ТипРасчета
                      |    ИЗ
                      |        РегистрРасчета.БУОсновныеНачисления КАК БУОсновныеНачисления
                      |    ГДЕ
                      |        БУОсновныеНачисления.ФизЛицо = &ФизЛицо И БУОсновныеНачисления.ПериодРегистрации = &НужныйПериод
                      |
                      |    ОБЪЕДИНИТЬ ВСЕ
                      |
                      |    ВЫБРАТЬ
                      |        УдержанияРаботниковОрганизаций.ФизЛицо,
                      |        ПРЕДСТАВЛЕНИЕ(УдержанияРаботниковОрганизаций.ФизЛицо),
                      |        УдержанияРаботниковОрганизаций.ВидРасчета,
                      |        ПРЕДСТАВЛЕНИЕ(УдержанияРаботниковОрганизаций.ВидРасчета),
                      |        -УдержанияРаботниковОрганизаций.Результат,
                      |        ""Удержания""
                      |    ИЗ
                      |        РегистрРасчета.УдержанияРаботниковОрганизаций КАК УдержанияРаботниковОрганизаций
                      |    ГДЕ
                      |        УдержанияРаботниковОрганизаций.ФизЛицо = &ФизЛицо И УдержанияРаботниковОрганизаций.ПериодРегистрации = &НужныйПериод) КАК ВложенныйЗапрос
                      |ИТОГИ СУММА(Результат)
                      |ПО ОБЩИЕ, ТипРасчета";
                      Как организовать сторнирование уже произведенных расчетов прошлых периодов?
                      ExpandedWrap disabled
                        ТаблицаСторноЗаписей = Движения.ОсновныеНачисленияРаботниковОрганизации.ПолучитьДополнение();
                         
                        Для каждого СтрокаСторно Из ТаблицаСторноЗаписей Цикл
                         
                            // Добавить сторно-записи в набор записей регистра.
                            // Новая запись движений.
                            Движение = Движения.ОсновныеНачисленияРаботниковОрганизации.Добавить();
                         
                            // Заполнить свойства.
                            Движение.ПериодРегистрации = Строка.ПериодРегистрацииСторно;
                            Движение.ПериодДействияНачало = Строка.ПериодДействияНачалоСторно;
                            Движение.ПериодДействияКонец = Строка.ПериодДействияКонецСторно;
                            Движение.БазовыйПериодНачало = Строка.БазовыйПериодНачало;
                            Движение.БазовыйПериодКонец = Строка.БазовыйПериодКонец;
                            Движение.ВидРасчета = Строка.ВидРасчета;
                            Движение.Сторно = Истина;
                         
                            // Заполнить измерения.
                            Движение.ФизЛицо = Строка.ФизЛицо;
                            Движение.Приказ = Строка.Приказ;
                            Движение.Организация = Строка.Организация;
                         
                            // Ресурсы не заполнять, потому что здесь не происходит расчет,
                            // только подготовка новой записи
                         
                            // Заполнить реквизиты.
                            Движение.ГрафикРаботы = Строка.ГрафикРаботы;
                            Движение.Размер = Строка.Размер;
                            Движение.ВидУчетаВремени = Строка.ВидУчетаВремени;
                            Движение.ПодразделениеОрганизации = Строка.ПодразделениеОрганизации;
                            Движение.ПериодРасчетаСреднегоЗаработкаНачало = Строка.ПериодРасчетаСреднегоЗаработкаНачало;
                            Движение.ПериодРасчетаСреднегоЗаработкаОкончание = Строка.ПериодРасчетаСреднегоЗаработкаОкончание;
                        КонецЦикла;
                         
                        Движения.ОсновныеНачисленияРаботниковОрганизации.Записать();
                        Бизнес-процессы
                        Как определить бизнес процесс, в котором количество последовательных этапов определяется индивидуально на момент старта экземпляра процесса?
                        ExpandedWrap disabled
                          Процедура ПередВыполнением(Отказ)
                                  Если Исполнитель.Пустая() Тогда
                                         Исполнитель = ПараметрыСеанса.ТекущийИсполнитель;
                                  КонецЕсли;
                                  ДатаВыполнения=ТекущаяДата();
                          КонецПроцедуры
                           
                          ПолучитьФорму("Маршрут").Открыть();
                          СтандартнаяОбработка = Ложь;
                           
                          Если ТочкиМаршрута.Количество() = 0 Тогда
                                  Сообщить("Не определен маршрут!!!");
                                  Отказ = Истина;
                          КонецЕсли;
                           
                          Результат = ПолучитьТочкуМаршрута().Пустая();
                           
                          Функция ПолучитьТочкуМаршрута()
                                  Запрос=Новый Запрос;
                                  Запрос.Текст= "ВЫБРАТЬ ПЕРВЫЕ 1
                                  |       НаМаршрутеТочкиМаршрута.НомерСтроки КАК НомерСтроки,
                                  |       НаМаршрутеТочкиМаршрута.Склад
                                  |ИЗ
                                  |       БизнесПроцесс.НаМаршруте.ТочкиМаршрута КАК НаМаршрутеТочкиМаршрута
                                  |ГДЕ
                                  |       (НаМаршрутеТочкиМаршрута.Склад НЕ В
                                  |                                     (ВЫБРАТЬ РАЗЛИЧНЫЕ
                                  |                                             ЭтапПути.Склад
                                  |                                     ИЗ
                                  |                                             Задача.ЭтапПути КАК ЭтапПути
                                  |                                     ГДЕ
                                  |                                             ЭтапПути.БизнесПроцесс = &БизнесПроцесс ))
                             |    И
                                  |       (Ссылка = &БизнесПроцесс)
                                  |УПОРЯДОЧИТЬ ПО
                                  | НомерСтроки";
                           
                                  Запрос.УстановитьПараметр("БизнесПроцесс", Ссылка);
                           
                                  Выборка = Запрос.Выполнить().Выбрать();
                           
                                  Если Выборка.Следующий() Тогда
                                         Возврат (Выборка.Склад);
                                  
                                  Иначе
                                         Возврат(Справочники.Склады.ПустаяСсылка());
                                  КонецЕсли;
                           
                          КонецФункции
                           
                          ФормируемыеЗадачи[0].Склад = ПолучитьТочкуМаршрута();
                           
                          ПолучитьФорму("ПутевойЛист").Открыть();
                          СтандартнаяОбработка = Ложь;
                           
                          Если ПоказанияСпидометраКонечные = 0 ИЛИ Ссылка.РасходТоплива = 0 Тогда
                                  Сообщить("Не введены данные по путевому листу!");
                                  Отказ = Истина;
                          КонецЕсли;
                          Как при работе с бизнес процессами отказаться от стандартного способа формирования задачи и сформировать ее программно?
                          ExpandedWrap disabled
                            Для Каждого Рецензент Из НаСогласование Цикл
                                    НоваяЗадача = Задачи.ЭтапПути.СоздатьЗадачу();
                                    НоваяЗадача.БизнесПроцесс = Ссылка;
                                    НоваяЗадача.Пользователь = Рецензент.Рецензент;
                                    НоваяЗадача.Наименование = "Согласование со специалистом";
                                    НоваяЗадача.ТочкаМаршрута = БизнесПроцессы.НаПараллельноеСогласование.ТочкиМаршрута.Согласование;
                                    НоваяЗадача.Дата = ТекущаяДата();
                                    НоваяЗадача.Записать();
                                    
                                    ФормируемыеЗадачи.Добавить(НоваяЗадача);
                            КонецЦикла;
                             
                            СтандартнаяОбработка = Ложь;
                            Прочие прикладные объекты
                            Как, не открывая форму внешней обработки, выполнить ее процедуру для определенного объекта?
                            ExpandedWrap disabled
                              Обработка = ВнешниеОбработки.Создать(ИмяФайла);
                               
                              Обработка.Печать(Ссылка);
                              Как быстро получить информацию, по всем объектам, находящимся в компетенции конкретного менеджера (элемент справочника "Пользователи") по продажам?
                              1.
                              ExpandedWrap disabled
                                МассивСсылок = КритерииОтбора.КомпетенцияМенеджераПродаж.Найти(Менеджер);
                                Для Каждого Ссылка из МассивСсылок Цикл
                                        Сообщить(Ссылка);
                                КонецЦикла;

                              2.
                              ExpandedWrap disabled
                                ВЫБРАТЬ
                                        КомпетенцияМенеджераПродаж.Ссылка
                                ИЗ
                                        КритерийОтбора.КомпетенцияМенеджераПродаж(&Менеджер) КАК КомпетенцияМенеджераПродаж
                                Формы и элементы управления
                                Работа с формами
                                Как открыть форму документа?
                                ExpandedWrap disabled
                                  ФормаДокумента = СсылкаНаДокумент.ПолучитьФорму();
                                  ФормаДокумента.Открыть();
                                  Как открыть форму внешней обработки?
                                  ExpandedWrap disabled
                                    Обработка = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
                                    Обработка.Открыть();
                                     
                                    //либо так:
                                    Обработка = ВнешниеОбработки.ПолучитьФорму("C:\Внешние\СпецОтчет.epf", ИмяФормы, , Ключ);
                                    Обработка.Открыть();
                                    Как отрыть форму отчета так, чтобы она не перекрывала собой ту форму, из которой она открыта?
                                    ExpandedWrap disabled
                                      Форма = Отчеты.ОтчетДиаграмма.ПолучитьФорму("ФормаОсновная", ЭтаФорма);
                                      Форма.ПоложениеОкна = ВариантПоложенияОкна.НеПерекрыватьВладельца;
                                      Форма.Открыть();
                                      Как открыть форму отчета на весь экран?
                                      ExpandedWrap disabled
                                        СпособОтображенияОкна = ВариантСпособаОтображенияОкна.Максимизированное;
                                        ИзмененятьСпособОтображенияОкна = ИзменениеСпособаОтображенияОкна.Запретить;
                                        Как из формы документа открыть форму списка данного документа, спозиционировавшись на нем же?
                                        ФормаСписка = Документы[Метаданные().Имя].ПолучитьФормуСписка();
                                        ФормаСписка.ПараметрТекущаяСтрока = Ссылка;
                                        ФормаСписка.Открыть();
                                        ФормаСписка = Документы[Метаданные().Имя].ПолучитьФормуСписка( , , Новый УникальныйИдентификатор());
                                        В документе есть реквизит "Контрагент". Как открыть форму подчиненного ему справочника "ДоговорыКонтрагентов"?
                                        ExpandedWrap disabled
                                          Если Не Контрагент.Пустая() Тогда
                                                  ФормаПодчиненныхДоговоров = Справочники.ДоговорыКонтрагентов.ПолучитьФормуСписка();
                                                  ФормаПодчиненныхДоговоров.ПараметрОтборПоВладельцу = Контрагент;
                                                  ФормаПодчиненныхДоговоров.Открыть();
                                          КонецЕсли;
                                          Как в форме отобразить картинку, сохраненную в реквизите справочника?
                                          ExpandedWrap disabled
                                            // Значение, сохраненное в реквизите справочника, имеющем тип
                                            // ХранилищеЗначения, можно только получить.
                                            СохраненнаяКартинка = Фотография.Получить();
                                             
                                            Если СохраненнаяКартинка <> Неопределено Тогда
                                                     // Если в хранилище было что-нибудь заранее записано…
                                                    ЭлементыФормы.Фото.Картинка = СохраненнаяКартинка;
                                            КонецЕсли;
                                            Как в журнале документов "УчетКадров" отобрать только документы "ПриемНаРаботу"?
                                            ExpandedWrap disabled
                                              ЖурналДокументовСписок.Отбор.ВидДокумента.Установить(Метаданные.Документы.ПриемНаРаботу);
                                              Как узнать интервал дат в открытом текущем журнале?
                                              ExpandedWrap disabled
                                                Если ЖурналДокументовСписок.Отбор.Дата.Использование Тогда
                                                        Сообщить(ЖурналДокументовСписок.Отбор.Дата);
                                                 
                                                Иначе
                                                        Сообщить("Без ограничения по датам");
                                                КонецЕсли;
                                                Как при открытии справочника сделать отбор по контрагентам, входящим в список?
                                                ExpandedWrap disabled
                                                  Процедура ПриОткрытии()
                                                          СправочникСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
                                                          СправочникСписок.Отбор.Ссылка.Значение = СписокКонтрагентов;
                                                          СправочникСписок.Отбор.Ссылка.Использование = Истина;
                                                   КонецПроцедуры
                                                  Как обеспечить, чтобы для выбора значения покупателя в расходной накладной справочник контрагенты открывался сразу с открытой группой "Покупатели"?
                                                  ExpandedWrap disabled
                                                    Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка)
                                                     
                                                            Если Элемент.Значение.Пустая() Тогда
                                                                   СтандартнаяОбработка = Ложь;
                                                                   ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора( , Элемент);
                                                                   ФормаВыбора.ВыборПокупателя = Истина;
                                                                   ФормаВыбора.Открыть();
                                                            КонецЕсли;
                                                     
                                                    КонецПроцедуры
                                                     
                                                    Если ВыборПокупателя Тогда
                                                            ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
                                                            ЭлементыФормы.СправочникСписок.ТекущийРодитель = Константы.ГруппаПокупатели.Получить();
                                                    КонецЕсли;
                                                     
                                                    Если ВыборПокупателя Тогда
                                                            ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
                                                            ЭлементыФормы.СправочникСписок.ТекущийРодитель = Справочники.Контрагенты.Покупатели;
                                                    КонецЕсли;
                                                    Табличное поле
                                                    Как запретить пользователю изменять порядок следования колонок в табличном поле?
                                                    ExpandedWrap disabled
                                                      ЭлементыФормы.ТабличноеПоле.ИзменятьПозициюКолонок = Ложь;
                                                      ЭлементыФормы.ТабличноеПоле.Колонки.Картинка.ИзменятьПозицию = Ложь;
                                                      ЭлементыФормы.ТабличноеПоле.Колонки.Код.ИзменятьПозицию = Ложь;
                                                      ЭлементыФормы.ТабличноеПоле.Колонки.Наименование.ИзменятьПозицию = Ложь;
                                                      Как запретить пользователю изменять любые настройки колонок табличного поля?
                                                      ExpandedWrap disabled
                                                        ЭлементыФормы.ТабличноеПоле.ИзменятьНастройкуКолонок = Ложь;
                                                        ЭлементыФормы.ТабличноеПоле.Колонки.Картинка.ИзменятьНастройку = Ложь;
                                                        ЭлементыФормы.ТабличноеПоле.Колонки.Код.ИзменятьНастройку = Ложь;
                                                        ЭлементыФормы.ТабличноеПоле.Колонки.Наименование.ИзменятьНастройку = Ложь;
                                                        Как вывести информацию о том, какой отбор установлен в журнале документов?
                                                        ExpandedWrap disabled
                                                          ЭлементыФормы.НадписьОтбор.Заголовок = СписокДокументов.Отбор;
                                                          УстановленныйОтбор = СписокДокументов.Отбор;
                                                          Сообщить("Элементы отбора:");
                                                           
                                                          Для Каждого ЭлементОтбора из УстановленныйОтбор Цикл
                                                                  Сообщить(Строка(ЭлементОтбора) + " использование = " + ЭлементОтбора.Использование);
                                                          КонецЦикла;
                                                          Как в форме справочника установить курсор на элемент с известным наименованием?
                                                          ExpandedWrap disabled
                                                            ЭлементыФормы.СправочникСписок.ТекущаяСтрока = Справочники.Контрагенты.НайтиПоНаименованию("ПОСТАВЩИКИ", Истина);
                                                            Как в форме списка сделать отбор по значению реквизита?
                                                            ExpandedWrap disabled
                                                               СправочникСписок.Отбор.СтавкаНДС.Установить(Перечисления.СтавкиНДС.НДС18);
                                                               
                                                              СправочникСписок.Отбор.СтавкаНДС.Значение = Перечисления.СтавкиНДС.НДС18;
                                                              СправочникСписок.Отбор.СтавкаНДС.ВидСравнения = ВидСравнения.Равно;
                                                              СправочникСписок.Отбор.СтавкаНДС.Использование = Истина;
                                                              Как запретить выдачу сообщения: "Введенные данные не отображены в списке, так как не соответствуют отбору" при добавлении новых элементов в справочник?
                                                              ExpandedWrap disabled
                                                                ЭлементыФормы.ПолеСписка.ПроверкаОтображенияНовойСтроки = ВариантПроверкиОтображенияНовойСтроки.НеПроверять;
                                                                Как заполнить ячейку табличного поля данными?
                                                                ExpandedWrap disabled
                                                                  Процедура ТабличноеПолеЗаказовЗаказПриИзменении(Элемент)
                                                                   
                                                                          // Получить текущую строку табличного поля.
                                                                          СтрокаТаблицы = ЭлементыФормы.ТабличноеПолеЗаказов.ТекущаяСтрока;
                                                                   
                                                                          // Ввести значения в ячейки строки.
                                                                          СтрокаТаблицы.Контрагент = СтрокаТаблицы.Заказ.Контрагент;
                                                                          СтрокаТаблицы.ДатаОтгрузки = СтрокаТаблицы.Заказ.ДатаОтгрузки;
                                                                   
                                                                  КонецПроцедуры
                                                                  Как изменить цвет фона ячейки табличного поля в зависимости от значения, выводимого в нее?
                                                                  ExpandedWrap disabled
                                                                    Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
                                                                     
                                                                            Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
                                                                                   ЗначениеЯчейкиОстаток = ОформлениеСтроки.Ячейки.Остаток.Значение;
                                                                            
                                                                                   Если ЗначениеЯчейкиОстаток <> Неопределено Тогда
                                                                     
                                                                                           Если ЗначениеЯчейкиОстаток < 10 Тогда
                                                                                                   ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Красный;
                                                                     
                                                                                           ИначеЕсли ЗначениеЯчейкиОстаток > 100 Тогда
                                                                                                   ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Желтый;
                                                                                           КонецЕсли;
                                                                                   КонецЕсли;
                                                                            КонецЦикла;
                                                                     
                                                                    КонецПроцедуры
                                                                    Как в табличное поле "ВыбранныеКонтрагенты" добавить новую колонку "ОсновнойДоговор", заполнить ее значения и дать возможность открытия этих значений?
                                                                    ExpandedWrap disabled
                                                                      Если ТаблицаКонтрагентов.Колонки.Найти("ОсновнойДоговор") = Неопределено Тогда
                                                                              МассивТипов = Новый Массив();
                                                                              МассивТипов.Добавить(Тип("СправочникСсылка.ДоговорыКонтрагентов"));
                                                                              ОписаниеНужныхТипов = Новый ОписаниеТипов(МассивТипов);
                                                                              ТаблицаКонтрагентов.Колонки.Добавить("ОсновнойДоговор", ОписаниеНужныхТипов);
                                                                      КонецЕсли;
                                                                       
                                                                      Для Каждого СтрокаТаблицы из ТаблицаКонтрагентов Цикл
                                                                              СтрокаТаблицы["ОсновнойДоговор"] = СтрокаТаблицы["Контрагент"]["ОсновнойДоговорКонтрагента"];
                                                                      КонецЦикла;
                                                                       
                                                                      ЭлементыФормы.ВыбранныеКонтрагенты.СоздатьКолонки();
                                                                      ЭлементыФормы.ВыбранныеКонтрагенты.Колонки.ОсновнойДоговор.ЭлементУправления.КнопкаОткрытия = Истина;
                                                                      Как задать список выбора для колонки "ВидДокумента" табличного поля?
                                                                      ExpandedWrap disabled
                                                                        Процедура ПриОткрытии()
                                                                         
                                                                                СписокВидовДокументов = Новый СписокЗначений;
                                                                                
                                                                                Для Каждого ДокументКонфигурации из Метаданные.Документы Цикл
                                                                                       СписокВидовДокументов.Добавить(ДокументКонфигурации.Имя);
                                                                                КонецЦикла;
                                                                         
                                                                                ЭлементыФормы.ПодборДанных.Колонки.ВидДокумента.ЭлементУправления.СписокВыбора = СписокВидовДокументов;
                                                                         
                                                                        КонецПроцедуры
                                                                         
                                                                        ЭлементыФормы.ПодборДанных.Колонки.ВидДокумента.ЭлементУправления.КнопкаСпискаВыбора = Истина;
                                                                        Как обеспечить возможность отбора и сортировки данных по реквизитам, не отображаемым в табличном поле формы списка справочника?
                                                                        ExpandedWrap disabled
                                                                          ЭлементыФормы.СправочникСписок.НастройкаОтбора.ОсновнойПоставщик.Доступность = Истина;
                                                                          ЭлементыФормы.СправочникСписок.НастройкаПорядка.ОсновнойПоставщик.Доступность = Истина;
                                                                          Как реализовать перетаскивание между элементами управления?
                                                                          ExpandedWrap disabled
                                                                            Процедура НоменклатураНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)
                                                                             
                                                                                    // Получить значение, переданное системой.
                                                                                    Значение = ПараметрыПеретаскивания.Значение;
                                                                             
                                                                                    // В любом случае значением будет массив.
                                                                                    МассивЗначений = Новый Массив;
                                                                             
                                                                                    // Если перетаскивается группа, то в массив записываем входящие в нее элементы.
                                                                                    Если Значение.ЭтоГруппа Тогда
                                                                                           Выборка = Справочники.Номенклатура.Выбрать(Значение);
                                                                                           Пока Выборка.Следующий() Цикл
                                                                                                   Если Не Выборка.ЭтоГруппа Тогда
                                                                                                           МассивЗначений.Добавить(Выборка.Ссылка);
                                                                                                   КонецЕсли;
                                                                                           КонецЦикла;
                                                                                    Иначе
                                                                                           МассивЗначений.Добавить(Значение);
                                                                                    КонецЕсли;
                                                                             
                                                                                    // Заполненный массив записываем в параметры.
                                                                                    ПараметрыПеретаскивания.Значение = МассивЗначений;
                                                                             
                                                                            КонецПроцедуры
                                                                             
                                                                            Процедура ТоварыПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
                                                                             
                                                                                    СтандартнаяОбработка = Ложь;
                                                                             
                                                                            КонецПроцедуры
                                                                             
                                                                            Процедура ТоварыПеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
                                                                             
                                                                                    ПолученныйМассив = ПараметрыПеретаскивания.Значение;
                                                                                    Если ТипЗнч(ПолученныйМассив) = Тип("Массив") Тогда
                                                                                           Для Каждого Значение Из ПолученныйМассив Цикл
                                                                                                   НоваяСтрока = ДокументОбъект.Товары.Добавить();
                                                                                                   НоваяСтрока.Номенклатура = Значение;
                                                                                                   НоваяСтрока.Количество = 1;
                                                                                           КонецЦикла;
                                                                                    КонецЕсли;
                                                                             
                                                                            КонецПроцедуры
                                                                            Как вывести остатки на складах в списке номенклатуры?
                                                                            ExpandedWrap disabled
                                                                              Процедура СписокНоменклатураПриПолученииДанных(Элемент, ОформленияСтрок)
                                                                               
                                                                                      Запрос = Новый Запрос("ВЫБРАТЬ
                                                                                      |       ТоварыНаСкладахОстатки.КоличествоОстаток КАК Остаток,
                                                                                      |       ТоварыНаСкладахОстатки.Номенклатура.Ссылка КАК Товар
                                                                                      |ИЗ
                                                                                      |       РегистрНакопления.ТоварыНаСкладах.Остатки( , Номенклатура В (&МассивТоваров)) КАК ТоварыНаСкладахОстатки");
                                                                               
                                                                                      МассивНоменклатуры = Новый Массив; // для передачи в параметр запроса
                                                                                      Соответствие = Новый Соответствие; // для заполнения остатков в строках табличного поля
                                                                               
                                                                                      Для Каждого Строка из ОформленияСтрок Цикл
                                                                                             МассивНоменклатуры.Добавить(Строка.ДанныеСтроки.Ссылка);
                                                                                             Соответствие.Вставить(Строка.ДанныеСтроки.Ссылка, Строка);
                                                                                      КонецЦикла;
                                                                               
                                                                                      Запрос.УстановитьПараметр("МассивТоваров", МассивНоменклатуры);
                                                                               
                                                                                      Выборка = Запрос.Выполнить().Выбрать();
                                                                               
                                                                                      // Вывести остаток в строку, найденную в соответствии по номенклатуре
                                                                                      // из запроса.
                                                                                      Пока Выборка.Следующий() Цикл
                                                                                             Соответствие.Получить(Выборка.Товар.Ссылка).Ячейки.Остаток.Значение = Выборка.Остаток;
                                                                                      КонецЦикла;
                                                                               
                                                                              КонецПроцедуры
                                                                              Другие элементы управления
                                                                              В форме есть панель со страницами. Как разместить картинку на закладке?
                                                                              ExpandedWrap disabled
                                                                                ЭлементыФормы.ОсновнаяПанель.Страницы.СчетаУчета.КартинкаЗаголовка = БиблиотекаКартинок.ДебетКредит;
                                                                                Как обеспечить, чтобы при открытии формы уже записанного элемента справочника "Контрагенты" активной была закладка "СчетаИДоговоры" панели "Панель"?
                                                                                ExpandedWrap disabled
                                                                                  Процедура ПриОткрытии()
                                                                                   
                                                                                          Если ЭтоНовый() = Ложь Тогда
                                                                                                 ЭлементыФормы.Панель.ТекущаяСтраница = ЭлементыФормы.Панель.Страницы.СчетаИДоговоры;
                                                                                          КонецЕсли;
                                                                                   
                                                                                  КонецПроцедуры
                                                                                  Как организовать выбор из нескольких списков документов для открытия?
                                                                                  ExpandedWrap disabled
                                                                                    Док = Метаданные.Документы;
                                                                                    СписокДокументов = Новый СписокЗначений();
                                                                                     
                                                                                    СписокДокументов.Добавить(Док.ПлатежноеПоручениеИсходящее, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ПлатежноеПоручениеВходящее, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.АккредитивПереданный, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.АккредитивПолученный, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ПлатежноеТребованиеВыставленное, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ПлатежноеТребованиеПолученное, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПереданное, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПолученное, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ПлатежныйОрдерСписаниеДенежныхСредств, , Ложь);
                                                                                    СписокДокументов.Добавить(Док.ПлатежныйОрдерПоступлениеДенежныхСредств, , Ложь);
                                                                                     
                                                                                    Если СписокДокументов.ОтметитьЭлементы("Укажите, какие списки документов открыть") Тогда
                                                                                            Для Каждого НазваниеДокумента из СписокДокументов Цикл
                                                                                                   Если НазваниеДокумента.Пометка Тогда
                                                                                                           ФормаСписка = Документы[НазваниеДокумента.Значение.Имя].ПолучитьФормуСписка();
                                                                                                           ФормаСписка.Открыть();
                                                                                                   КонецЕсли;
                                                                                            КонецЦикла;
                                                                                    КонецЕсли;
                                                                                    Как можно организовать подстановку обращения к персоне?
                                                                                    ExpandedWrap disabled
                                                                                      Процедура ПерсонаОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
                                                                                       
                                                                                              Значение = Новый СписокЗначений();
                                                                                              Значение.Добавить("Уважаемый " + Текст);
                                                                                              Значение.Добавить("Уважаемая " + Текст);
                                                                                              Значение.Добавить("Уважаемое " + Текст);
                                                                                              Значение.Добавить("Уважаемые " + Текст);
                                                                                              Значение.Добавить(Текст);
                                                                                       
                                                                                              СтандартнаяОбработка = Ложь;
                                                                                       
                                                                                      КонецПроцедуры
                                                                                      Как в командной панели создать подменю с кнопками?
                                                                                      ExpandedWrap disabled
                                                                                        КнопкиКоманднойПанели = ЭлементыФормы.КоманднаяПанельФормы.Кнопки;
                                                                                         
                                                                                        // Проверить, нет ли уже на командной панели кнопки "Сформировать".
                                                                                        // Если есть - удалить.
                                                                                        Индекс = КнопкиКоманднойПанели.Индекс(КнопкиКоманднойПанели.Найти("Сформировать"));
                                                                                         
                                                                                        Если Индекс = -1 Тогда
                                                                                                Индекс = 0;
                                                                                        Иначе
                                                                                                КнопкиКоманднойПанели.Удалить(Индекс);
                                                                                        КонецЕсли;
                                                                                         
                                                                                        // Создать подменю "Сформировать".
                                                                                        ПодменюСформировать = КнопкиКоманднойПанели.Вставить(Индекс, "Сформировать", ТипКнопкиКоманднойПанели.Подменю, "Сформировать");
                                                                                         
                                                                                        // Добавить картинку.
                                                                                        ПодменюСформировать.Картинка = БиблиотекаКартинок.Сформировать;
                                                                                        ПодменюСформировать.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
                                                                                         
                                                                                        // Опросить перечисление о возможных вариантах периодичности.
                                                                                        Запрос = Новый Запрос("ВЫБРАТЬ Ссылка ИЗ Перечисление.Периодичность");
                                                                                        Выборка = Запрос.Выполнить().Выбрать();
                                                                                         
                                                                                        //Добавить кнопки к подменю.
                                                                                        Пока Выборка.Следующий() Цикл
                                                                                                Период = Выборка.Ссылка;
                                                                                                ПодменюСформировать.Кнопки.Добавить("кн" + Период, ТипКнопкиКоманднойПанели.Действие, "Сформировать за " + Период, Новый Действие("КнопкаСформироватьНажатие"));
                                                                                        КонецЦикла;
                                                                                         
                                                                                        Процедура КнопкаСформироватьНажатие(Элемент)
                                                                                         
                                                                                                НазваниеПериодичности = СтрЗаменить(Элемент.Имя, "кн", "");  
                                                                                         
                                                                                        КонецПроцедуры
                                                                                        Как созданной кнопке назначить "горячие клавиши"?
                                                                                        ExpandedWrap disabled
                                                                                          СозданнаяКнопка.СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша.L, Истина, Истина,);
                                                                                          Как реализовать заполнение возможных значений поля выбора "ОбрабатываемаяТабличнаяЧасть" при заполнении поля ввода "ОбрабатываемыйДокумент"?
                                                                                          ExpandedWrap disabled
                                                                                            Процедура ОбрабатываемыйДокументПриИзменении(Элемент)
                                                                                             
                                                                                                    СписокВыбора = ЭлементыФормы.ОбрабатываемаяТабличнаяЧасть.СписокВыбора;
                                                                                                    СписокВыбора.Очистить();
                                                                                             
                                                                                                    Если Элемент.Значение <> Неопределено И Не(Элемент.Значение.Пустая()) Тогда
                                                                                                           ТабличныеЧасти = Элемент.Значение.Метаданные().ТабличныеЧасти;
                                                                                                          
                                                                                                           Для Каждого ТабличнаяЧасть из ТабличныеЧасти Цикл
                                                                                                                   СписокВыбора.Добавить(ТабличнаяЧасть);
                                                                                                           КонецЦикла;
                                                                                                    КонецЕсли;
                                                                                             
                                                                                            КонецПроцедуры
                                                                                             
                                                                                            Процедура ОбрабатываемыйДокументОчистка(Элемент, СтандартнаяОбработка)
                                                                                             
                                                                                                    ОбрабатываемаяТабличнаяЧасть = "";
                                                                                             
                                                                                            КонецПроцедуры
                                                                                            Если пользователь указал несколько дат в поле календаря - как их перебрать?
                                                                                            ExpandedWrap disabled
                                                                                              КоллекцияДат = ЭлементыФормы.ПолеКалендаря.ВыделенныеДаты;
                                                                                               
                                                                                              Для каждого ДатаКалендаря из КоллекцияДат Цикл
                                                                                                      Сообщить(ДатаКалендаря);
                                                                                              КонецЦикла;
                                                                                              ЭлементыФормы.ПолеКалендаря.РежимВыделения = РежимВыделенияДаты.Множественный;
                                                                                              Как организовать работу с индикатором?
                                                                                              ExpandedWrap disabled
                                                                                                Выборка = РезультатЗапроса.Выбрать();
                                                                                                Индикатор = ЭлементыФормы.ИндикаторПеребора;
                                                                                                Индикатор.МаксимальноеЗначение = Выборка.Количество();
                                                                                                Индикатор.Значение = 0;
                                                                                                 
                                                                                                Пока Выборка.Следующий() Цикл
                                                                                                        Индикатор.Значение = Индикатор.Значение + 1;
                                                                                                КонецЦикла;
                                                                                                 
                                                                                                Выборка = РезультатЗапроса.Выбрать();
                                                                                                Индикатор = ЭлементыФормы.ИндикаторПеребора;
                                                                                                Индикатор.МаксимальноеЗначение = Выборка.Количество();
                                                                                                Индикатор.Значение = 0;
                                                                                                Индикатор.ОтображатьПроценты = Истина;
                                                                                                Индикатор.СтильОтображения = РежимСглаживанияИндикатора.Прерывистый;
                                                                                                Индикатор.Ориентация = Ориентация.Вертикально;
                                                                                                Индикатор.Шаг = 0.1;
                                                                                                 
                                                                                                Пока Выборка.Следующий() Цикл
                                                                                                        Индикатор.Значение = Индикатор.Значение + 1;
                                                                                                КонецЦикла;
                                                                                                Как у элемента управления сменить источник данных?
                                                                                                ExpandedWrap disabled
                                                                                                  Процедура КнопкаВыполнитьНажатие(Элемент)
                                                                                                   
                                                                                                          ЭлементыФормы.ТП.Данные = "СписокКонтрагентов";
                                                                                                          ЭлементыФормы.ТП.СоздатьКолонки();
                                                                                                   
                                                                                                  КонецПроцедуры
                                                                                                   
                                                                                                  Процедура Номенклатура(Кнопка)
                                                                                                   
                                                                                                          ЭлементыФормы.ТП.Данные = "СписокНоменклатуры";
                                                                                                          ЭлементыФормы.ТП.СоздатьКолонки();
                                                                                                   
                                                                                                  КонецПроцедуры
                                                                                                  Как задать представление даты, отображаемое в поле ввода по-умолчанию?

                                                                                                  ЭлементыФормы.ПолеВвода1.Формат = "ДП='01.01.0001'";

                                                                                                  ЭлементыФормы.ПолеВвода1.Формат = "ДП='00:00:00'";

                                                                                                  ЭлементыФормы.ПолеВвода1.Формат = "ДП='01.01.0001 00:00:00'";
                                                                                                    Как вывести текст в поле картинки в том случае, если картинка не выбрана?
                                                                                                    ExpandedWrap disabled
                                                                                                      ЭлементыФормы.ОсновноеИзображение.ТекстНевыбраннойКартинки = "фотография номенклатуры отсутствует";
                                                                                                      Как открыть пользователю стандартный диалог выбора цвета?
                                                                                                      ExpandedWrap disabled
                                                                                                        Диалог = Новый ДиалогВыбораЦвета;
                                                                                                        Если Диалог.Выбрать() Тогда
                                                                                                                ВыбранныйЦвет = Диалог.Цвет;
                                                                                                        КонецЕсли;
                                                                                                        Диалог = Новый ДиалогВыбораШрифта;
                                                                                                        Если Диалог.Выбрать() Тогда
                                                                                                                ВыбранныйШрифт = Диалог.Шрифт;
                                                                                                        КонецЕсли;
                                                                                                        Как заполнить список в форме данными запроса?
                                                                                                        ExpandedWrap disabled
                                                                                                          Запрос = Новый Запрос("
                                                                                                          |ВЫБРАТЬ
                                                                                                          |       Номенклатура.Ссылка КАК Значение,
                                                                                                          |       Номенклатура.Представление КАК Представление,
                                                                                                          |       ИСТИНА КАК Пометка
                                                                                                          |ИЗ
                                                                                                          |       Справочник.Номенклатура КАК Номенклатура
                                                                                                          |ГДЕ
                                                                                                          |       Номенклатура.ОсновнойПоставщик = &ОсновнойПоставщик");
                                                                                                           
                                                                                                          Запрос.УстановитьПараметр("ОсновнойПоставщик", ПолеПоставщик);
                                                                                                           
                                                                                                          Выборка = Запрос.Выполнить().Выбрать();
                                                                                                           
                                                                                                          Пока Выборка.Следующий() Цикл
                                                                                                                  ЗаполнитьЗначенияСвойств(ПолеСписка.Добавить(), Выборка);
                                                                                                          КонецЦикла;
                                                                                                          Как отобразить в форме файл графической схемы?
                                                                                                          ExpandedWrap disabled
                                                                                                            Схема = Новый ГрафическаяСхема();
                                                                                                            Схема.Прочитать("D:/MyScheme.grs");
                                                                                                            ЭлементыФормы.СтруктурнаяСхема.УстановитьСхему(Схема);
                                                                                                          0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                                                                                                          0 пользователей:


                                                                                                          Рейтинг@Mail.ru
                                                                                                          [ Script execution time: 0,1316 ]   [ 17 queries used ]   [ Generated: 1.08.21, 02:23 GMT ]