На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное RSS
msm.ru
! Этот раздел предназначен для заполнения/проверки/рехтования/* содержимого будущего FAQ и не более того.
Все вопросы касательно 1С следует задавать здесь: 1С: Проблемы и решения
Модераторы: evGenius
Страницы: (3) [1] 2 3  все  ( Перейти к последнему сообщению )  
> Вопросы-ответы№4, format complete, осталось проверить
    Subj
    Коллеги, Евгений Гилев и Насипов Фарит проводят новый тренинг по разработке на мобильной платформе 1С.
    Кому интересно – подробности здесь: http://kursy-po-1c.ru/mobile-apps
    http://kursy-po-1c.ru/mobile-apps.
      Интерфейсы, стили
      Как задать различные стили 1С:Предприятия для различных категорий пользователей?
      ExpandedWrap disabled
        ОсновнойИнтерфейс = ПользователиИнформационнойБазы.ТекущийПользователь().ОсновнойИнтерфейс.Имя;
        Если ОсновнойИнтерфейс = "ИнтерфейсКассира" Тогда
            ГлавныйСтиль = БиблиотекаСтилей.СтильКассира;
        ИначеЕсли ОсновнойИнтерфейс = "Планирование" Тогда
            ГлавныйСтиль = БиблиотекаСтилей.СтильПланирования;
        Иначе
            ГлавныйСтиль = БиблиотекаСтилей.Основной;
        КонецЕсли;
        Есть список имен интерфейсов с пометками. Как сделать помеченные интерфейсы видимыми?
        ExpandedWrap disabled
          СтрокаИменИнтерфейсов = "";
          Для Каждого ИмяИнтерфейса из СписокИнтерфесов Цикл
                  Если ИмяИнтерфейса.Пометка Тогда
                         СтрокаИменИнтерфейсов = СтрокаИменИнтерфейсов + ИмяИнтерфейса + ",";
                  КонецЕсли;
          КонецЦикла;
          ГлавныйИнтерфейс.ПереключитьИнтерфейс(СтрокаИменИнтерфейсов);
          Как из формы обработки отключить глобальный обработчик ожиданий?
          ExpandedWrap disabled
            Процедура ПриНачалеРаботыСистемы()
                    ПодключитьОбработчикОжидания("ПроверкаОпроса", 60);
            КонецПроцедуры
             
            Процедура ОтказОтОпроса() Экспорт
                    ОтключитьОбработчикОжидания("ПроверкаОпроса");
            КонецПроцедуры
             
            ОтказОтОпроса();
            Запросы, отчеты

            Как получить данные из табличной части документов?
            ExpandedWrap disabled
              ВЫБРАТЬ РАЗЛИЧНЫЕ
                      РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура
              ИЗ
                      Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
              Как получить данные из табличной части документов и представить их в иерархическом виде?
              ExpandedWrap disabled
                ВЫБРАТЬ РАЗЛИЧНЫЕ
                        РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура
                ИЗ
                        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                ИТОГИ ПО
                        Номенклатура ТОЛЬКО ИЕРАРХИЯ
                Как подсчитать количество одинаковых элементов в выбираемых данных?
                ExpandedWrap disabled
                  ВЫБРАТЬ
                      РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
                      СУММА(РеализацияТоваровУслугТовары.Количество) КАК Количество
                  ИЗ
                      Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                  СГРУППИРОВАТЬ ПО
                      РеализацияТоваровУслугТовары.Номенклатура
                  Как применять условия для отбора по значениям полей, вычисленных как результат агрегатной функции?
                  ExpandedWrap disabled
                    ВЫБРАТЬ
                        РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
                        СУММА(РеализацияТоваровУслугТовары.Количество) КАК Количество
                    ИЗ
                        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                    СГРУППИРОВАТЬ ПО
                        РеализацияТоваровУслугТовары.Номенклатура
                    ИМЕЮЩИЕ
                        СУММА(РеализацияТоваровУслугТовары.Количество) > 10
                    Как ограничить выборку из виртуальной таблицы?
                    ExpandedWrap disabled
                      ВЫБРАТЬ
                          ПродажиОбороты.Номенклатура КАК Номенклатура
                      ИЗ
                          РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон) КАК ПродажиОбороты
                      Как просуммировать данные по одинаковым значениям одного из полей выборки?
                      ExpandedWrap disabled
                        ВЫБРАТЬ
                            ПродажиОбороты.Подразделение КАК Подразделение,
                            ПродажиОбороты.Номенклатура КАК Номенклатура,
                            ПродажиОбороты.КоличествоОборот,
                            ПродажиОбороты.СтоимостьОборот КАК СтоимостьОборот
                        ИЗ
                            РегистрНакопления.Продажи.Обороты((&ДатаНач, &ДатаКон) КАК ПродажиОбороты
                        ИТОГИ СУММА(СтоимостьОборот) ПО
                            Подразделение
                        Как получить только те записи, в которых значение определенного поля превышает указанное значение?
                        ExpandedWrap disabled
                          ВЫБРАТЬ
                              ПродажиОбороты.Подразделение КАК Подразделение,
                              ПродажиОбороты.Номенклатура КАК Номенклатура,
                              ПродажиОбороты.КоличествоОборот,
                              ПродажиОбороты.СтоимостьОборот КАК СтоимостьОборот
                          ИЗ
                              РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон, , Подразделение = &Подразделение) КАК ПродажиОбороты
                          ГДЕ
                              ПродажиОбороты.КоличествоОборот > &Порог
                          Как обратиться к подчиненным полям в запросе?
                          ExpandedWrap disabled
                            ВЫБРАТЬ
                                ПродажиОбороты.ДоговорКонтрагента.Владелец,
                                ПродажиОбороты.КоличествоОборот,
                                ПродажиОбороты.СтоимостьОборот КАК СтоимостьОборот
                            ИЗ
                                РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон) КАК ПродажиОбороты
                             
                            ВЫБРАТЬ
                                ПродажиОбороты.ДоговорКонтрагента.Владелец,
                                СУММА(ПродажиОбороты.КоличествоОборот) КАК КоличествоОборот,
                                СУММА(ПродажиОбороты.СтоимостьОборот) КАК СтоимостьОборот
                            ИЗ
                                РегистрНакопления.Продажи.Обороты((&ДатаНач, &ДатаКон) КАК ПродажиОбороты
                            СГРУППИРОВАТЬ ПО
                                ПродажиОбороты.ДоговорКонтрагента.Владелец
                            Как объединить результаты нескольких запросов?
                            ExpandedWrap disabled
                              ВЫБРАТЬ РАЗЛИЧНЫЕ
                                  РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура
                              ИЗ
                                  Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
                              ОБЪЕДИНИТЬ
                               
                              ВЫБРАТЬ РАЗЛИЧНЫЕ
                                  РеализацияТоваровУслугВозвратнаяТара.Номенклатура
                              ИЗ
                                  Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслугВозвратнаяТара
                              ОБЪЕДИНИТЬ
                               
                              ВЫБРАТЬ РАЗЛИЧНЫЕ
                                  РеализацияТоваровУслугУслуги.Номенклатура
                              ИЗ
                                  Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслугУслуги
                              Как выбрать данные из двух таблиц, удовлетворяющие определенному условию?
                              ExpandedWrap disabled
                                ВЫБРАТЬ
                                    ЗаказыПокупателейОстатки.Номенклатура,
                                    ЗаказыПокупателейОстатки.КоличествоОстаток КАК ЗаказаноПокупателями,
                                    ЗаказыПоставщикамОстатки.КоличествоОстаток КАК ЗаказаноПоставщикам
                                ИЗ
                                    РегистрНакопления.ЗаказыПокупателей.Остатки(&ДатаОтч) КАК ЗаказыПокупателейОстатки
                                    ВНУТРЕННЕЕ СОЕДИНЕНИЕ
                                        РегистрНакопления.ЗаказыПоставщикам.Остатки(&ДатаОтч) КАК ЗаказыПоставщикамОстатки
                                    ПО
                                        ЗаказыПокупателейОстатки.Номенклатура = ЗаказыПоставщикамОстатки.Номенклатура
                                Как дополнить данные одной таблицы данными, выбранными из другой таблицы по определенному условию?
                                ExpandedWrap disabled
                                  ВЫБРАТЬ
                                          ЗаказыПокупателейОстатки.Номенклатура,
                                          ЗаказыПокупателейОстатки.КоличествоОстаток КАК ЗаказаноПокупателями,
                                          ЗаказыПоставщикамОстатки.КоличествоОстаток КАК ЗаказаноПоставщикам
                                  ИЗ
                                          РегистрНакопления.ЗаказыПокупателей.Остатки(&ДатаОтч) КАК ЗаказыПокупателейОстатки
                                          ЛЕВОЕ СОЕДИНЕНИЕ
                                                 РегистрНакопления.ЗаказыПоставщикам.Остатки(&ДатаОтч) КАК ЗаказыПоставщикамОстатки
                                          ПО
                                                 ЗаказыПокупателейОстатки.Номенклатура = ЗаказыПоставщикамОстатки.Номенклатура
                                0 пользователей читают эту тему (0 гостей и 0 скрытых пользователей)
                                0 пользователей:
                                Страницы: (3) [1] 2 3  все


                                Рейтинг@Mail.ru
                                [ Script Execution time: 0,1440 ]   [ 18 queries used ]   [ Generated: 15.12.19, 23:33 GMT ]