На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное DigiMania RSS
msm.ru
  
> Ошибка при проверке входа в COPSSH для взаимодействия с git
    Здравствуйте

    Что я сделал:
    1. Установил систему контроля версий git (C:\Progs\Programming\git\)
    2. Настроил git
    3. Установил сервер COPSSH (C:\Progs\Programming\copssh_x86\)
    4. После установки у меня появился каталог "ivan", который находится тут "C:\Progs\Programming\copssh_x86\home\"
    5. В каталоге "ivan" находиться такой набор файлов и каталог:
    5.1 .ssh (каталог)
    5.2 authorized_keys (Файл в нутри каталога .ssh)
    5.3 .bash_profile
    5.4 .bashrc
    5.5 .inputrc
    5.6 IVAN-PC_2048.ppk

    Затем сказано проверьте, как всё установилось.
    Сделал следующее, вошёл в git bash и ввёл команду:

    ExpandedWrap disabled
      ssh ivan@IVAN-PC


    В место того, что бы было выполнено успешно, выполняется с предупреждением в добавок не действует пароль при вводе его. Пишет сообщение "Permission denied, please try again.".

    Для наглядности прилагаю скриншот.

    Что же я делаю не так, помогите пожалуйста разобраться?
    Прикреплённая картинка
    Прикреплённая картинка
    Сообщение отредактировано: zuze -
      Все правильно сделано, только там, где смотрит сервер SSHd, нет пароля, который ты вводишь.

      Введи его для пользователя ivan, и будет тебе счастье.

      Под Unix, если нет пользователя, он создается через adduser и через passwd ему устанавливается пароль.

      Как это работает под виндой мне неизвестно, сам разбирайся.
        Цитата p1qb0d @

        Все правильно сделано, только там, где смотрит сервер SSHd, нет пароля, который ты вводишь.

        Введи его для пользователя ivan, и будет тебе счастье.

        Под Unix, если нет пользователя, он создается через adduser и через passwd ему устанавливается пароль.

        Как это работает под виндой мне неизвестно, сам разбирайся.


        Большое спасибо.

        Я задал пароль для пользователя "ivan". Предупреждение осталось таким же, но вот ошибка после ввода пароля поменялась.
        Теперь пишется

        ExpandedWrap disabled
          "Connection to ivan-pc closed by remote host. Connection to ivan-pc closed."


        Для наглядности прилагаю скриншот.

        Я думал, что если задам пароль, то он распространиться на всю систему, но как я понял не на всю. Нужно что-то ещё настроить, но не могу понять в каком направлении искать информацию о том, что нужно настроить.
        Прикреплённая картинка
        Прикреплённая картинка
          Прилагаю содержание файлов "authorized_keys" и "known_hosts". Может это прольёт свет почему у меня не работает.

          В файле "authorized_keys", такая информация:
          ExpandedWrap disabled
            ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDi+XZPwXlvN1ThokXDrsvMRjLugIz1+bzyAZAKr/2tTZv11XjpXleD4a7+jrANLIbR/AsigOjhqgpIqYeMnlDv9o9QIR27pjmV90M2ciYWr86kXDO7guiyY35MHnlQuEkzzP+nP8E8Opq07CBYnGFJKHYZnumvBkBmELD29gETZC3Ah7gu+JZIK7KYJ6ZhN944xesIAjcj12/X1pqOEik+SbhLqNUmiDqCLSUcFqwEGwiDV5Ijm0geyJm15D04HZAwp/zLxKKasQlM5KuEFk5s9cTVzPFfukS/kPnNK/Mrpa+Iw8VC+lv4wxNkDTfPT6+1f3LVwE6RjHCHFwxy2dzf ivan@IVAN-PC timestamp: 1460967154


          В файле "known_hosts", такая информация:
          ExpandedWrap disabled
            ivan-pc,fe80::14f6:1f33:b501:8600%11 ecdsa-sha2-nistp256 AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBKDeBiU2yngdX9RKwPb2bqJizhnUkGOlT5iOx8aggPGap6J7j1fJvcXB7LGiCRJPKTnXEqauumumENZ+v8zcR20=


          Добавлено
          Возможно, что вся проблема в том, что пользователь "ivan" в системе находиться по такому пути "С:\Users\", а пользователь "ivan" на сервере SSH находиться по такому адресу "C:\Progs\Programming\copssh_x86\home\".

          Но так было сказана в инструкции по установки сервера SSH поэтому такой путь и задал.
            Вот подробная отладочная информация:

            ExpandedWrap disabled
              ssh -vvv ivan@IVAN-PC


            user posted image

            user posted image
              Решил посмотреть порт 22 открыт ли он и к какому IP он привязан. Он открыт, но привязан к IP: 0.0.0.0, а не к моему IP. Думаю проблема в этом. Как же сделать так, что бы порт 22 был открыт на конкретном IP?

              Смог поменять IP прописав в файле (sshd_config):

              ExpandedWrap disabled
                ListenAddress <Мой IP>


              Но это не помогло.
              Сообщение отредактировано: zuze -
                Судя по скринам, пароль набирается правильный.

                После правильной проверки на пароль в Unix запускается shell.

                У тебя тоже запускается.

                Если shell неправильный, то происходит "досвиданья", как в твоем случае.

                Нужно проверить виндовый аналог /etc/passwd на предмет прописанного для Вани шелла, а также возможную проверку на допустимость. Если в файле /etc/shells указанного шелла нет, он может рассматриваться как невалидный, даже если он совершенно валиден, и будет "досвиданья".
                  IP 0.0.0.0 говорит о том что слушаются все локальные IP адреса, необходимости прописывать конкретный нет необходимости.

                  Но можно, если с определенных интерфейсов это не нужно по соображениям безопасности.

                  Так что и не должно было помочь.
                  1 пользователей читают эту тему (1 гостей и 0 скрытых пользователей)
                  0 пользователей:


                  Рейтинг@Mail.ru
                  [ Script Execution time: 0,0932 ]   [ 18 queries used ]   [ Generated: 19.06.19, 06:57 GMT ]