На главную
ПРАВИЛА FAQ Помощь Участники Календарь Избранное DigiMania RSS
msm.ru
! Правила раздела:

  • Перед тем, как задать вопрос, желательно почитать документацию и воспользоваться поиском.
  • Когда задаёте вопрос, то обязательно указывайте платформу (7.7, 8.0, 8.1, 8.2, etc), причем желательно в заголовке. Если речь идёт о типовой конфигурации, то указывайте её название и релиз. Текущие версии можно посмотреть здесь.
  • Ещё раз напоминаем о необходимости соблюдать не только правила, но и законы. Уважайте авторские права.

Высказать своё мнение о модераторах раздела можно здесь: evGenius
Модераторы: evGenius
  
> Синхронизация Бух 3.0 и Управление небольшой фирмой 1.6
    При обмене данными из 3.0 в фирму 1.6(прямое соединение) поступление товаров выдает такое окно:

    Не пойму где ошибка
    Прикреплённый файлПрикреплённый файл1ccrap.png (16,17 Кбайт, скачиваний: 83)
    "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
      Правила и конфигурации типовые?
      Стандартные пляски с бубном - очистка кэша и т.д. пробовал?
      Когда последний раз обновления баз ставил?
      В обеих конфигурациях правила соответствуют релизам баз корреспондентов?
      [А что Если… КонецЕсли]
        Цитата Rust @
        В обеих конфигурациях правила соответствуют релизам баз корреспондентов?

        Как это проверить?
        "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
          Цитата ^D^ima @
          Как это проверить?


          Цитата Информация из файла "Совместное использование"
          Для определения значения контролируемых параметров, которые загружены в конфигурации, нужно выполнить следующие действия.
          Открыть созданную настройку синхронизации данных.
          - В командной панели открывшейся формы нажать «Параметры обмена данными – Открыть правила конвертации объектов».
          - Проконтролировать информацию о правилах обмена. Например:
          - Правила обмена
          Дата создания: 01.07.2014 14:20:14
          Конфигурация-источник: Управление небольшой фирмой, редакция 1.5 (1.5.1)
          Конфигурация-приемник: Бухгалтерия предприятия, редакция 3.0 (3.0.34)

          Для определения значения контролируемых параметров, которые входят в поставку конфигураций, нужно выполнить следующие действия:

          - В форме настройки "Правила конвертации объектов" нажать кнопку «Информация о файле правил».
          - Выбрать файл правил конвертации из комплекта поставки конфигурации.
          - При настройке синхронизации данных на стороне конфигурации «Управление небольшой фирмой» файл следует искать в каталоге обновления. При настройке синхронизации данных на стороне конфигурации «Бухгалтерия предприятия» – в подкаталоге "Обмены данными – Обмен с конфигурацией Управление небольшой фирмой, ред. 1.6".
          Данные действия также следует производить последовательно для обеих конфигураций, которые участвуют в синхронизации данных.

          Если источник правил – правила из внешнего файла, то необходимо осуществить дополнительную проверку. Для этого:

          - необходимо сохранить копию используемых правил в файл с помощью кнопки «Выгрузить правила формы правил конвертации»;
          - установить переключатель «Источник правил» в положение «Типовые правила из конфигурации»;
          - нажать кнопку «Загрузить правила»;
          - посмотреть представленную информацию о правилах.

          В результате проверки правил обмена принимается одно из решений:

          - Продолжить использование текущих правил конвертации и правил регистрации.
          - Использовать свежие правила из комплекта правил конфигурации-корреспондента. Порядок загрузки описан в файле Инструкция по подключению правил обмена.txt.
          - Использовать вместо правил из внешнего источника типовые, встроенные в конфигурацию правила конвертации и правила регистрации объектов.
          Для этого в командной панели формы узла плана обмена в подменю Параметры синхронизации данных выбрать команду Открыть правила конвертации объектов (Правила регистрации объектов). Далее необходимо установить переключатель Источник правил в положение Типовые правила конвертации (Типовые правила регистрации) и нажать кнопку Загрузить правила.
          [А что Если… КонецЕсли]
            После обновления баз эта проблема ушла, но другая осталась.
            Я хочу Из бух перенести Покупки - поступление(акты, накладные)

            Состав отправляемых данных выдает 131 данного документ(всего 293), а в Управление небольшой фирмой 1.6 как было 3 , так и осталось. В чем подвох???

            Смотрю логи:
            База Бух - отправлено 293
            База небольшой фирмы - обработано 160. WTF???

            это означает что нельзя сопоставить аналог этого документа в управление фирмой????
            Прикреплённый файлПрикреплённый файл1c1.png (24,88 Кбайт, скачиваний: 75)
            Прикреплённый файлПрикреплённый файл1c2.png (17,21 Кбайт, скачиваний: 71)
            Прикреплённый файлПрикреплённый файл1c3.png (11,06 Кбайт, скачиваний: 70)
            Прикреплённый файлПрикреплённый файл1c4.png (12,68 Кбайт, скачиваний: 69)
            "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
              Посмотрел для бухи 3.0.45.20.
              По правилам обмена из бухи в унф поступления не выгружаются.
              Проводится поиск по внутреннему идентификатору, и если объект не найден в базе приемнике (УНФ), то новый не создается.
              Подразумевается что поступление было уже выгружено из УНФ в БУХ, а при обратной выгрузке проводится только проверка существования.

              P/S/
              Цитата ^D^ima @
              Смотрю логи:
              База Бух - отправлено 293
              База небольшой фирмы - обработано 160. WTF???

              Это количество объектов всего, не только документов.
              [А что Если… КонецЕсли]
                Цитата Rust @
                По правилам обмена из бухи в унф поступления не выгружаются.

                Вот я так и понял :(
                "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                  Если операция разовая - набросай правила для переноса и перенеси обработкой "Универсальный обмен данными в формате XML" (V8Exchan83.epf).
                  Займет вместе с отладкой 2-3 часа. Больше всего времени отнимает настройка тыканьем на всякие галочки в правилах.
                  [А что Если… КонецЕсли]
                    Rust
                    там сильное несоответствие полей и табличных частей :( Пока я понял почему не происходит переноса, это главное, спасибо
                    "Воля - это то, что заставляет тебя побеждать, когда твой рассудок говорит тебе, что ты повержен" Карлос Кастанеда
                    1 пользователей читают эту тему (1 гостей и 0 скрытых пользователей)
                    0 пользователей:


                    Рейтинг@Mail.ru
                    [ Script Execution time: 0,0980 ]   [ 18 queries used ]   [ Generated: 22.02.18, 07:02 GMT ]